Bug 995384 - [EAP 6.1] Starting host controller in domain mode fails on solaris 10 sparc
[EAP 6.1] Starting host controller in domain mode fails on solaris 10 sparc
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.2
Unspecified Solaris
high Severity high
: ER02
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 04:39 EDT by Radim Hatlapatka
Modified: 2014-01-02 15:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:36:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of error when starting host controller of EAP 6 (75.05 KB, image/png)
2013-09-12 08:08 EDT, Radim Hatlapatka
no flags Details

  None (edit)
Description Radim Hatlapatka 2013-08-09 04:39:05 EDT
Description of problem:
It is similar issue as https://bugzilla.redhat.com/show_bug.cgi?id=911327, but it occurs for different operation: start host controller.

To me it occurs only on solaris 10 sparc, I guess the timeout should be also increased and made configurable

Version-Release number of selected component (if applicable):
Detected with JON 3.1.2 including EAP Plugin Pack Hotfix-03 for JBoss ON 3.1.2 with EAP 6.1.1.ER4
:
Steps to Reproduce:
1.import EAP 6.1 in domain mode
2.go to host controller
3.first stop the host controller, then start it
Comment 1 Radim Hatlapatka 2013-08-09 04:43:46 EDT
Just for completeness, the error message given by JON:

java.lang.Exception: Was not able to start the server at org.rhq.core.pc.operation.OperationInvocation.run(OperationInvocation.java:278) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:724)
Comment 3 Thomas Segismont 2013-09-12 07:46:53 EDT
Can you please attach the full log file?
Comment 4 Radim Hatlapatka 2013-09-12 08:08:28 EDT
Created attachment 796820 [details]
Screenshot of error when starting host controller of EAP 6

I have uploaded screenshot from time this error occurred. It doesn't happen every time.
Comment 7 Thomas Segismont 2013-09-13 08:58:41 EDT
I had a closer look at the screenshot and I don't think this is a duplicate of BZ911327.

In JON 3.1.2, EAP6 plugin executes the managed server start script and then waits for the server to start before reporting the operation result. The "wait for the server to start" logic is as follows:
* try to connect to the http management interface and read a server attribute
* if you can, then we can report the server has started
* if you can't, sleep 1 second and try again, unless you already tried 20 times

This behavior has changed as part of the fix for BZ966777. Now the agent retries until the operation invocation is interrupted (operation timed out).

The default time out for operations should be high enough to let your slow starting server show up.
Comment 8 Libor Zoubek 2013-11-15 05:31:51 EST
verified on JON 3.2.ER5

Note You need to log in before you can comment on or make changes to this bug.