Bug 995439 - JTS transactions settings depend on Jacorb settings [NEEDINFO]
JTS transactions settings depend on Jacorb settings
Status: CLOSED DUPLICATE of bug 1107869
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Brian Stansberry
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 07:24 EDT by Ondrej Chaloupka
Modified: 2014-10-25 08:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
When JTS is enabled in the `Transactions` section of the web management console ("Profile -> Container -> Transactions"), it it is necessary to also set the attribute `transactions` to the value `on` in the JacORB subystem. The intended behaviour is that transactions are enabled when JTS is enabled. The cause of this issue is under investigation. Until it is resolved, the workaround is to ensure that the `transactions` attribute is also set to `on`. Note that the transactions subsystem is available only in the `full` and `full-ha` profiles.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-03 08:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
hbraun: needinfo? (bstansberry)


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2013-08-09 07:24:30 EDT
There is and check box to enable JTS transactions under Profile -> Container -> Transactions. This action puts <jts/> tag under the transaction subsystem.

But for correct jts transaction initialization it is necessary to set attribute transactions to value 'on' in jacorb subystem as well. This is currently not happening.

This subsystem is accessible just in full and full-ha profiles.
Comment 1 Jakub Cechacek 2013-08-09 08:06:16 EDT
This is probably not a console issue - it works the same way in CLI too. I would say that missing validation in underlying resource definition is the problem here.
Comment 2 Ondrej Chaloupka 2013-08-09 08:13:13 EDT
It depends on the point of view.
Yes in CLI it works as you are saying but under cli I need to go under subsystem call method etc. It means that user exactly knows what he is doing - adding <jts/> tag element under transaction subsytem.
Console offers easy configuration to user - with graphical gui without needed to know what is exactly happening under the cover.

I would expect that when I set JTS to true in console that the jts would be correctly set (initialized). But this is not true.
Comment 3 Chao Wang 2013-08-13 06:28:57 EDT
https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6/html-single/Development_Guide/index.html#Configure_the_ORB_for_JTS_Transactions
We have a section to indicate user how to configure ORB for JTS with Management Console. If user follow the doc, I think they should be aware to this change.
Comment 5 Heiko Braun 2013-10-01 02:23:15 EDT
Brian, can you comment on this? Dealing with cross subsytem constraints is not trivial on the console. Especially with RBAC in place.
Comment 7 Ondrej Chaloupka 2013-10-09 02:56:03 EDT
Hi Brian, Hi Heiko,

I understand the possible technical problems but I consider this quite unhappy for users. Especially when you decide to change the transaction to jts when running the standalone.xml. The console permits do such change but restart will fail afterwards (as jacorb subsytem is not present).

Would be possible (as first step) add some note to the webconsole next to the parameter that the jts settings has some limitation?
Comment 8 Brian Stansberry 2013-10-09 11:01:53 EDT
The description text for the attribute that the server provides and that I *think* the console uses for tooltip text can include something about this. I'll have a look and see if I can get that in right now.
Comment 10 Brian Stansberry 2013-10-09 22:28:29 EDT
I updated the description.
Comment 11 Harald Pehl 2014-07-03 08:07:57 EDT
Fixed as part of BZ1107869

*** This bug has been marked as a duplicate of bug 1107869 ***

Note You need to log in before you can comment on or make changes to this bug.