Bug 995470 - KIE module injection through CDI does no...
KIE module injection through CDI does no...
Status: CLOSED DUPLICATE of bug 955193
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Edson Tirelli
Marek Winkler
Depends On:
  Show dependency treegraph
Reported: 2013-08-09 09:15 EDT by swati.sen12
Modified: 2013-08-22 04:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-22 04:15:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description swati.sen12 2013-08-09 09:15:04 EDT
Created attachment 738552 [details]
server.log with deployment error

Description of problem:

Injection of KIE module through CDI fails on JBoss EAP 6.0/6.1 due to wrong processing of resource URI when loading pom.properties in ClasspathKieProject.

Version-Release number of selected component (if applicable):

BRMS 6.0.0.Beta1
EAP 6.0, 6.1.ER4

How reproducible:

Deploy the attached reproducer WAR. Deployment fails, server.log contains the following error (see attachment for all errors in log):

15:40:29,923 INFO  [stdout] (MSC service thread 1-2) kmodules: vfs:/content/kie-cdi-war-web-app-1.0.0-SNAPSHOT.war/WEB-INF/lib/kie-cdi-war-kie-module-1.0.0-SNAPSHOT.jar/META-INF/kmodule.xml
15:40:29,939 ERROR [org.drools.compiler.kie.builder.impl.ClasspathKieProject] (MSC service thread 1-2) Unable to load pom.properties from/content/kie-cdi-war-web-app-1.0.0-SNAPSHOT.war/WEB-INF/lib/kie-cdi-war-kie-module-1.0.0-SNAPSHOT.jar as jarPath cannot be found

The first log line shows that ClasspathKieProject located kmodule.xml at URL starting with protocol 'vfs:'. Later, in method fixURLFromKProjectPath, the protocol prefix is removed, leading to URL /content/kie-cdi-war-web-app-1.0.0-SNAPSHOT.war/WEB-INF/lib/kie-cdi-war-kie-module-1.0.0-SNAPSHOT.jar which now references absolute path which is wrong.

Steps to Reproduce:
1. Deploy attached reproducer WAR on EAP 6.
2. Watch server.log for deployment errors.
Actual results:

Deployment fails due to failed injection.

Expected results:

Application deploys successfully and writes INFO message into server.log.

Additional info:

This issue blocks further testing if KIE module injection through CDI. It also renders the CDI feature unusable in real environment (e.g. some web or EJB container with CDI).

[reply] [−] Comment 1 Marek Winkler 2013-04-22 10:18:01 EDT

Created attachment 738553 [details]
Maven project with reproducer WAR

Attached reproducer WAR which fails to deploy.

[reply] [−] Comment 2 Marek Winkler 2013-04-22 10:39:44 EDT

Comment on attachment 738553 [details]
Maven project with reproducer WAR

Maven project building reproducer WAR.

Attachment #738553 [details] - Attachment description: Reproducer WAR → Maven project with reproducer WAR
Lukáš Petrovický 2013-04-22 10:41:50 EDT
Assignee: etirelli@redhat.commproctor@redhat.com
[reply] [−] Comment 3 Marek Winkler 2013-04-22 10:47:41 EDT

I have uploaded maven project containing two modules:

- kie-module -- jar containing kmodule.xml, pom.properties and drl resources

- web-app -- the actual reproducer war

(In reply to comment #2)
> Comment on attachment 738553 [details]
> Maven project with reproducer WAR
> Maven project building reproducer WAR.

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:
Comment 2 Marek Winkler 2013-08-22 04:15:28 EDT
This BZ is a copy-paste of BZ 955193.

*** This bug has been marked as a duplicate of bug 955193 ***

Note You need to log in before you can comment on or make changes to this bug.