Bug 99549 - bash.info not referenced
Summary: bash.info not referenced
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: texinfo   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-21 19:49 UTC by Tom Tromey
Modified: 2014-08-11 05:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 16:58:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Tromey 2003-07-21 19:49:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
bash.info.gz appears in /usr/share/info.
However, it is not referenced from /usr/share/info/dir


Version-Release number of selected component (if applicable):
bash-2.05b-20.1

How reproducible:
Always

Steps to Reproduce:
1. grep bash /usr/share/info/dir
2.
3.
    

Additional info:

Comment 1 Tim Waugh 2003-07-21 20:15:32 UTC
'info bash' works for me.  Clean install, or upgrade?

Comment 2 Tom Tromey 2003-07-21 20:22:17 UTC
I upgraded from 7.3.

"info bash" works for me too.
Plain "info" followed by "m" "bash" fails though
Likewise, M-x info in Emacs brings up dir without a 'bash' entry

(BTW I have a lot of instance of this bug -- 18 different packages.
I'll be reporting the others later.  I wonder if this is some
systematic bug though...)


Comment 3 Tim Waugh 2003-07-22 10:22:39 UTC
info, m, bash works for me too.

This from the spec file:

# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
# to prevent prereq loops

And the info-dir file in the texinfo src.rpm has the right bit:

$ grep bash info-dir
* bash: (bash).                 The Bourne Again Shell.

Do you have an info.rpmnew by any chance?

Comment 4 Tom Tromey 2003-07-22 14:27:30 UTC
Yes, I do have /usr/share/info/dir.rpmnew
It has entries for "info" and "bash", and that's it.

Where can I learn about how RPMs install new info files?
I assumed it would happen using only install-info.
I'd like to try to figure out the problem before submitting
bugs against the other 17 packages that are missing dir entries...


Comment 5 Tim Waugh 2003-07-28 11:13:45 UTC
Not sure.  But .rpmnew files are created for %config(noreplace) files if they
have been modified from the original payload file.

Comment 6 Tom Tromey 2005-09-09 16:58:40 UTC
This has been fixed since at least FC2.
I couldn't think of a reason to leave it open.



Note You need to log in before you can comment on or make changes to this bug.