This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 995502 - rhevm-upgrade attempts to stop the ovirt-engine service when migrating from RHEV 3.0 to RHEV 3.1
rhevm-upgrade attempts to stop the ovirt-engine service when migrating from R...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.5
All Linux
high Severity high
: ---
: 3.3.0
Assigned To: Alex Lourie
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 10:36 EDT by Allan Voss
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 11:20:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Voss 2013-08-09 10:36:12 EDT
Description of problem:
When running the rhevm-upgrade to migrate from RHEV 3.0 to RHEV 3.1, the script attempts to stop the ovirt-engine service instead of the jbossas service


Version-Release number of selected component (if applicable):
rhevm-setup-3.1.0-55

How reproducible:
Very

Steps to Reproduce:
1. Build RHEV 3.0 environment
2. Change proper channels and run 'yum update rhevm-setup'
3. Run rhevm-upgrade to migration to 3.1


Actual results:
Script fails because it attempts to stop the non-existent ovirt-engine service

Expected results:
Script stops the jbossas service and continues the migration

Additional info:
The workaround is to manually edit the engine-upgrade script, and find:

def stopEngine(service=basedefs.ENGINE_SERVICE_NAME):

and relace basedefs.EXEC_SERVICE, service, "stop", 

with basedefs.EXEC_SERVICE, "jbossas", "stop",
Comment 22 Alex Lourie 2013-12-05 11:19:54 EST
The update to the upgrade article https://access.redhat.com/site/articles/269333 is published.
Comment 24 Sandro Bonazzola 2013-12-16 11:20:52 EST
Closing since the bug doesn't affect current release ( >= 3.2.0 ) and documentation exists for previous releases ( https://access.redhat.com/site/articles/269333 ).

Note You need to log in before you can comment on or make changes to this bug.