Bug 995545 - python-ldap needs python-pyasn1-modules
python-ldap needs python-pyasn1-modules
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-ldap (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Petr Spacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 12:54 EDT by Jens Kuehnel
Modified: 2014-10-10 12:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-ldap-2.4.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-08 15:14:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Kuehnel 2013-08-09 12:54:53 EDT
Description of problem:
python-ldap needs python-pyasn1-modules

Version-Release number of selected component (if applicable):
python-ldap-2.4.6-4.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1.yum install python-ldap
2. start python
3. type in: import ldap.controls.ppolicy

Actual results:
$ python
Python 2.7.5 (default, Jul  8 2013, 09:48:59) 
[GCC 4.8.1 20130603 (Red Hat 4.8.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import ldap.controls.ppolicy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/ldap/controls/ppolicy.py", line 20, in <module>
    from pyasn1.type import tag,namedtype,namedval,univ,constraint
ImportError: No module named pyasn1.type
>>> 


Expected results:
$python
Python 2.7.5 (default, Jul  8 2013, 09:48:59) 
[GCC 4.8.1 20130603 (Red Hat 4.8.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import ldap.controls.ppolicy
>>> 


Additional info:
add python-pyasn1-modules.noarch to required to fix problem.
Work around: yum install python-pyasn1-modules.noarch
Comment 1 Fedora Update System 2014-09-25 05:05:56 EDT
python-ldap-2.4.16-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-ldap-2.4.16-1.fc21
Comment 2 Fedora Update System 2014-09-25 06:12:41 EDT
python-ldap-2.4.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-ldap-2.4.16-1.fc20
Comment 3 lnie 2014-09-26 00:29:42 EDT
Tested with python-ldap-2.4.16-1.fc20,the dependency for python-pyasn1 is added,
but I still got traceback:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/ldap/controls/ppolicy.py", line 22, in <module>
    from pyasn1_modules.rfc2251 import LDAPDN
ImportError: No module named pyasn1_modules.rfc2251
Comment 4 Martin Kosek 2014-09-26 04:46:57 EDT
It looks like the Requires should be on the modules subpackage instead:

# rpm -ql python-pyasn1-modules | grep rfc2251
/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2251.py
/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2251.pyc
/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2251.pyo
Comment 5 Fedora Update System 2014-09-26 05:03:19 EDT
Package python-ldap-2.4.16-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-ldap-2.4.16-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11530/python-ldap-2.4.16-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-09-27 05:50:01 EDT
Package python-ldap-2.4.16-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-ldap-2.4.16-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11611/python-ldap-2.4.16-1.fc21
then log in and leave karma (feedback).
Comment 7 Petr Spacek 2014-09-29 10:40:55 EDT
I will fix it as part of rebase to python-ldap 2.4.17.
Comment 8 Fedora Update System 2014-09-29 11:01:37 EDT
python-ldap-2.4.17-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-ldap-2.4.17-1.fc21
Comment 9 Fedora Update System 2014-09-29 11:11:58 EDT
python-ldap-2.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-ldap-2.4.17-1.fc20
Comment 10 Fedora Update System 2014-10-01 00:18:29 EDT
Package python-ldap-2.4.17-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-ldap-2.4.17-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11885/python-ldap-2.4.17-1.fc21
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2014-10-08 15:14:05 EDT
python-ldap-2.4.17-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2014-10-10 12:12:03 EDT
python-ldap-2.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.