Bug 995552 - livecd-iso-to-disk has an upper limit of 2048 MB writing to FAT32 partitions but 4095 MB will work
livecd-iso-to-disk has an upper limit of 2048 MB writing to FAT32 partitions ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 13:10 EDT by M. Edward (Ed) Borasky
Modified: 2013-11-29 08:54 EST (History)
7 users (show)

See Also:
Fixed In Version: livecd-tools-20.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-29 08:54:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for livecd-iso-to-disk (2.25 KB, patch)
2013-08-09 13:10 EDT, M. Edward (Ed) Borasky
no flags Details | Diff

  None (edit)
Description M. Edward (Ed) Borasky 2013-08-09 13:10:18 EDT
Created attachment 784934 [details]
patch for livecd-iso-to-disk

Description of problem:
I'd say this is more an enhancement than a problem - livecd-iso-to-disk works as advertised. When writing to a FAT32 partition, --swap-size-mb, --overlay-size-mb and --home-size-mb are capped at 2 gigabytes, presumably because at one time somebody thought a file an a FAT32 partition couldn't be larger than 2 gigabytes (2^31-1 bytes). 

I've used files on FAT32 as large as 2^32-1 (4 GB) and they work on both Windows 8 and Linux. Moreover, 'liveusb-creator' actually will make a 4 GB persistent overlay. So I patched the livecd-iso-to-disk script to change to cap to 4095 MB and everything appears to work. I don't know what other testing / research is required before this can be changed, but I'm offering the attached patch.

Version-Release number of selected component (if applicable): 19.5-1.fc19
Comment 1 Fedora Update System 2013-11-18 18:03:36 EST
livecd-tools-20.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/livecd-tools-20.1-1.fc20
Comment 2 Fedora Update System 2013-11-19 16:52:02 EST
Package livecd-tools-20.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-20.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21725/livecd-tools-20.1-1.fc20
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-11-29 08:54:48 EST
livecd-tools-20.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.