This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 995589 - [RFE] Manifest Refresh does not make the autosubscribed clients go green even after receiving the right subscriptions
[RFE] Manifest Refresh does not make the autosubscribed clients go green even...
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
sthirugn@redhat.com
: FutureFeature
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2013-08-09 15:15 EDT by sthirugn@redhat.com
Modified: 2017-06-26 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 16:36:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-08-09 15:15:01 EDT
Description of problem:
Manifest Refresh does not make the autosubscribed clients go green even after receiving the right subscriptions

Version-Release number of selected component (if applicable):
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install SAM
2. Get a manifest from portal and upload it to SAM - say RHEL subscriptions for x86_64
3. Get couple of clients (RHEL x86_64) auto subscribed to SAM - Notice that the clients show GREEN (fully compliant) in SAM UI
# subscription-manager register --username $user --password $pass --org $org --autosubscribe
4. Go back to portal, remove the relevant subscriptions
5. Navigate to SAM UI -> Subscriptions -> Red Hat Subscriptions -> + Import Manifest -> Refresh Manifest
6. Notice that both the clients go RED (not compliant)
7. Now go back to portal, reattach all the relevant subscriptions
8. Navigate to SAM UI and Refresh Manifest again


Actual results:
The systems are still showing non-compliant (RED)
Tried running #rhsmcertd in the clients with no luck


Expected results:
The systems should be compliant (GREEN) once they get the right manifest during manifest refresh because they are auto-subscribed


Additional info:
Comment 1 sthirugn@redhat.com 2013-08-09 15:18:46 EDT
Realized that delete manifest also works in the same manner as above.
Comment 3 Tom McKay 2013-08-09 15:59:16 EDT
This certainly could be made an option on manifest import. For now, you may use the newly added "auto-attach all systems" button to perform this action.
Comment 4 sthirugn@redhat.com 2013-08-09 16:25:28 EDT
I agree "auto-attach all systems" should help for 1.3.
Comment 5 Bryan Kearney 2017-06-26 16:36:21 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.