Bug 995609 - Kernel 3.10.5-201 fails to boot on system w/ btrfs root filesystem
Kernel 3.10.5-201 fails to boot on system w/ btrfs root filesystem
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 16:09 EDT by chomskiii
Modified: 2013-09-23 16:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 16:33:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chomskiii 2013-08-09 16:09:44 EDT
Description of problem:

Upon rebooting after updating to kernel 3.10.5-201 and rebooting, system dropped into emergency shell.  Reviewing logs revealed that mount was complaining that 'btrfs' was an unknown filesystem.


Version-Release number of selected component (if applicable):
kernel-3.10.5-201.fc19.x86_64


How reproducible:
Unknown.  I only have one box running Fedora 19.  When I get home I plan on spinning up a Fedora 19 VM to see if I can replicate.


Steps to Reproduce:
1. Install kernel-3.10.5-201.fc19.x86_64 package
2. Reboot


Actual results:

The system aborts to emergency shell.  The system logs show the following:

Aug 09 12:35:59 localhost.localdomain mount[129]: mount: unknown filesystem time 'btrfs'
Aug 09 12:35:59 localhost.localdomain systemd[1]: sysroot.mount mount process exited, code=exited status=32
Aug 09 12:35:59 localhost.localdomain systemd[1]: Failed to mount /sysroot.
Aug 09 12:35:59 localhost.localdomain systemd[1]: Dependency failed for Initrd Root File System.
Aug 09 12:35:59 localhost.localdomain systemd[1]: Dependency failed for Reload Configuration from the Real Root.


Expected results:

Boot to login screen.
Comment 1 Josh Boyer 2013-08-15 09:32:30 EDT
Please look in /boot/ and ensure that the initramfs is of similar size to the rest of them.  Also, make sure the btrfs.ko module is in the initramfs for this kernel.  You can do this by running:

sudo lsinitrd /boot/initramfs-3.10.5-201.fc19.x86_64.img | grep btrfs.ko
Comment 2 Josh Boyer 2013-09-18 16:44:14 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Josef Bacik 2013-09-23 16:33:28 EDT
If this can be reproduced on a recent kernel please file a bugzilla at bugzilla.kernel.org and set the component to btrfs.

Note You need to log in before you can comment on or make changes to this bug.