Bug 995635 - [abrt] WARNING: at fs/btrfs/extent-tree.c:5501 __btrfs_free_extent+0x5e6/0xa00 [btrfs]()
[abrt] WARNING: at fs/btrfs/extent-tree.c:5501 __btrfs_free_extent+0x5e6/0xa0...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-btrfs
Fedora Extras Quality Assurance
abrt_hash:676b343b0ef64a195b5bcaeb441...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 18:50 EDT by al morris
Modified: 2013-09-23 16:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 16:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (86.55 KB, text/plain)
2013-08-09 18:50 EDT, al morris
no flags Details

  None (edit)
Description al morris 2013-08-09 18:50:54 EDT
Description of problem:
doing a yum update.... hope the new kernel has fewer oops than this one



Additional info:
reporter:       libreport-2.1.6
WARNING: at fs/btrfs/extent-tree.c:5501 __btrfs_free_extent+0x5e6/0xa00 [btrfs]()
Modules linked in: nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables bnep bluetooth rfkill ip6table_filter ip6_tables vfat fat snd_hwdep snd_seq acpi_cpufreq mperf kvm_amd kvm snd_seq_device joydev ses sp5100_tco k10temp enclosure snd_pcm crc32_pclmul snd_page_alloc fam15h_power crc32c_intel snd_timer snd r8169 ghash_clmulni_intel soundcore edac_core edac_mce_amd mii microcode i2c_piix4 serio_raw uinput binfmt_misc btrfs libcrc32c xor zlib_deflate raid6_pq usb_storage hid_logitech_dj nouveau video i2c_algo_bit drm_kms_helper mxm_wmi ttm drm i2c_core wmi
CPU: 4 PID: 1851 Comm: yum_childtask.p Not tainted 3.10.4-300.fc19.x86_64 #1
Hardware name: Gigabyte Technology Co., Ltd. To be filled by O.E.M./990FXA-UD3, BIOS FC 02/05/2013
 0000000000000009 ffff88077bd6bad8 ffffffff81643306 ffff88077bd6bb10
 ffffffff8105c211 ffff8808019f2510 00000000c1b08000 0000000000000000
 0000000000000100 0000000000000041 ffff88077bd6bb20 ffffffff8105c2ea
Call Trace:
 [<ffffffff81643306>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2ea>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa01fa2f6>] __btrfs_free_extent+0x5e6/0xa00 [btrfs]
 [<ffffffffa0256384>] ? btrfs_merge_delayed_refs+0x1f4/0x3d0 [btrfs]
 [<ffffffffa01fde32>] run_clustered_refs+0x362/0xdc0 [btrfs]
 [<ffffffffa0228b89>] ? btrfs_get_token_32+0x59/0xe0 [btrfs]
 [<ffffffffa01ef05d>] ? generic_bin_search.constprop.43+0x8d/0x1a0 [btrfs]
 [<ffffffffa020a49e>] ? btree_set_page_dirty+0xe/0x10 [btrfs]
 [<ffffffffa02029e0>] btrfs_run_delayed_refs+0xd0/0x4f0 [btrfs]
 [<ffffffffa0213af7>] __btrfs_end_transaction+0xc7/0x310 [btrfs]
 [<ffffffffa0213d50>] btrfs_end_transaction+0x10/0x20 [btrfs]
 [<ffffffffa021e672>] btrfs_evict_inode+0x2f2/0x330 [btrfs]
 [<ffffffff811b098e>] evict+0x9e/0x190
 [<ffffffff811b11b3>] iput+0xf3/0x180
 [<ffffffff811a50db>] do_unlinkat+0x1ab/0x240
 [<ffffffff811a7a36>] SyS_unlink+0x16/0x20
 [<ffffffff81651919>] system_call_fastpath+0x16/0x1b
Comment 1 al morris 2013-08-09 18:50:59 EDT
Created attachment 785031 [details]
File: dmesg
Comment 2 Josh Boyer 2013-09-18 16:51:23 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Josef Bacik 2013-09-23 16:18:33 EDT
Likely corruption in the extent tree.  Please make sure you have the latest btrfs-progs from git.kernel.org and run btrfsck /dev/whatever and see if it complains about anything, and if so run again with btrfsck --repair /dev/whatever.  If you still have issues please open a bugzilla at bugzilla.kernel.org and set the component to btrfs.

Note You need to log in before you can comment on or make changes to this bug.