Bug 995638 - psql buffers stderr in interactive mode
psql buffers stderr in interactive mode
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 19:02 EDT by rop
Modified: 2015-05-14 20:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:33:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rop 2013-08-09 19:02:40 EDT
Description of problem:

On OpenShift, when running psql interactively from command line, it seems like stderr is somehow buffered, thus all error-msgs remain hidden to the user until you exit the psql-session.
See short demo at:
  https://www.openshift.com/forums/openshift/psql-interactive-error-reporting

Version-Release number of selected component (if applicable):

  OpenShift in production 2013-08-09
  psql - 8.4.3

How reproducible:

See short demo at:
  https://www.openshift.com/forums/openshift/psql-interactive-error-reporting

Actual results:

  All error-msgs from psql seems to be buffered until you exit session.

Expected results:

  Errors should be displayed immediately when encountered interactively

Additional info:
Comment 1 openshift-github-bot 2013-11-05 16:36:09 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/a1d90f1fa848291b934281eabce1496540f5fa06
Fix bug 995638: do not store stderr in a variable during interactive psql
Comment 2 Yan Du 2013-11-06 22:23:57 EST
test on devenv 3998

[app2-111.dev.rhcloud.com 527b05139c35a10d6a000012]\> psql
psql (8.4.18)
Type "help" for help.

app2=# select foo from bar;
ERROR:  relation "bar" does not exist
LINE 1: select foo from bar;
                        ^
app2=# select count(*) from abc;
 count 
-------
     1
(1 row)

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.