Bug 99564 - Virtual consoles not available while first boot is running.
Virtual consoles not available while first boot is running.
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: firstboot (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-21 17:13 EDT by Nick Marsh
Modified: 2007-04-18 12:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 15:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Marsh 2003-07-21 17:13:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030516 Mozilla Firebird/0.6

Description of problem:
Virtual are consoles not available while firstboot is running. Additionally,
typing CTRL + ALT + Backspace won't break the firstboot process (as it did in
earlier versions). This is a problem if your xfree86 config was not setup
properly by anaconda because you can't get to the command line interface to fix it.

Version-Release number of selected component (if applicable):
firstboot-1.1.4-1

How reproducible:
Always

Steps to Reproduce:
1. Boot into firstboot process (either from fresh install or by rm
/etc/sysconfig/firstboot;chkconfig firstboot on;reboot)
2. Attempt to switch to virtual console (CTRL + ATL + F1-F6) or break X (CTRL +
ATL + Backspace)
    

Actual Results:  Can't access virtual consoles.

Expected Results:  Should be able to access the CLI and fix things if your X
config is hosed.

Additional info:

The only way I was able to even get into X was to pass grub the "single" option
and then remove my /etc/X11/XFree86Config file, run redhat-config-xfree86, and
init 5.
Comment 1 Bill Nottingham 2003-07-28 15:07:15 EDT
Firstboot runs as a service, hence it runs before /etc/init.d/rc finishes, hence
mingetty will not be running on any VTs.
Comment 2 Nick Marsh 2003-07-28 16:04:25 EDT
Well that sucks.

Note You need to log in before you can comment on or make changes to this bug.