Bug 995692 - regular user can reboot (II)
regular user can reboot (II)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-10 03:07 EDT by Gerard Torrent
Modified: 2013-09-12 15:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 15:35:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Torrent 2013-08-10 03:07:22 EDT
Description of problem:
A regular user can reboot system using command 'shutdown -r now'.

Version-Release number of selected component (if applicable):
systemd-204-9.fc19.x86_64

How reproducible:
Tested in a text console with only 1 user connected to system.

Steps to Reproduce:
1. turn on PC
2. log as a regular user
3. type 'shutdown -r now'

Actual results:
System reebots

Expected results:
Command execution denial + message 'Must be root.'

Additional info:
> uname -a
> Linux fobos 3.10.5-201.fc19.x86_64 #1 SMP Wed Aug 7 16:25:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
> sestatus
> SELinux status:                 disabled
Comment 1 Harald Hoyer 2013-08-14 12:18:31 EDT
The local console user can always do that. He can also switch of the system via the power button or pull the power cable.
Comment 2 Lennart Poettering 2013-09-12 15:35:02 EDT
This is not a bug, it's a feature, and users have been able to shutdown the system via GNOME's menu since ages. If you don't like this, please reconfigure PolicyKit to deny local users to shutdown the machine.

Note You need to log in before you can comment on or make changes to this bug.