Bug 995714 - Removing ovirt breaks dracut
Removing ovirt breaks dracut
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: 3.4.1
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-10 07:40 EDT by Tobias Oed
Modified: 2014-04-30 06:56 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 06:56:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18192 None None None Never

  None (edit)
Description Tobias Oed 2013-08-10 07:40:37 EDT
I installed ovirt some time ago and removed it the other day. This left an empty directory /usr/lib/dracut/modules.d/91ovirtnode belonging to no package.

Todays kernel update triggered dracut that failed because of this empty dir, reboot -> boum. (Removing the dir, rerunning dracut and fixing grub.cfg fixed the problem for me.)

That dir should belong to some rpm and should be removed when not needed anymore. 

F19 uptodate as of 2013-8-10

Tobias
Comment 1 Juan Hernández 2013-08-10 11:07:37 EDT
I'm moving the bug to the oVirt product, and to the ovirt-node component. This 91ovirtnode directory isn't created by the engine, and I'm not sure if it is related to oVirt node either.
Comment 2 Mike Burns 2013-08-15 10:15:38 EDT
should be a simple specfile change to remove that directory (or say that we own it.

It's also worth nothing that ovirt-node should *not* be installed on a running system, only in a ovirt-node iso.
Comment 3 Sandro Bonazzola 2014-03-04 04:22:00 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Note You need to log in before you can comment on or make changes to this bug.