This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 995739 - 'Previous' button disabled on some pages where it should be enabled
'Previous' button disabled on some pages where it should be enabled
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity low
: ER2
: 6.0.0
Assigned To: Thomas Hauser
Pavol Srna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-10 14:05 EDT by Pavol Srna
Modified: 2014-02-06 10:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:27:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Srna 2013-08-10 14:05:25 EDT
Description of problem:

The Previous button is disabled on some pages where it (under my opinion) should be enabled.
For example, a user should be able to navigate from the Create Shortcuts installer page back to the 'post-install summary'. 

I know that we don't support full undo, so when all the data are copied over we cannot go one step back, but there are still some installer pages when the previous button enabled makes sense.

I think these previous buttons should be enabled:

* on Create Shortcuts page
* on 'Post-Install Summary' page when 'Do not perform post-install configuration' was checked. User cannot navigate one step back and decide to perform some post-install configuration.
Comment 2 Miles Tjandrawidjaja 2013-08-13 09:00:43 EDT
Hey Pavol,

The installer has been modified so that even if the 'Do not perform post-install configuration' has been checked, the user will still see the 'Post-Install Summary' giving them a chance to go back to perform some post-install configurations.

http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=49c9f7aebbb53cc262047927434b51bd66e65a24

I don't think the Create Shortcuts page should have the previous button enabled due too complication with izpack. The Summary Panel should act as a final confirmation page when deciding the configuration of your installation.
Comment 3 Pavol Srna 2013-09-17 10:00:15 EDT
Verified in ER2 jboss-eap-6.1.0.soa.ci-installer.jar

Note You need to log in before you can comment on or make changes to this bug.