Bug 995766 - ThinLVM: Clone from snapshot fails, incorrect args passed to _create_volume()
ThinLVM: Clone from snapshot fails, incorrect args passed to _create_volume()
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: Upstream M3
: 4.0
Assigned To: Eric Harney
Giulio Fidente
:
Depends On:
Blocks: 975606 975916
  Show dependency treegraph
 
Reported: 2013-08-10 18:59 EDT by Eric Harney
Modified: 2016-04-26 11:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.9.b3.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: Bug in Cinder (Thin) LVM volume driver Consequence: Clone from snapshot operation fails Fix: Patch Cinder (Thin) LVM volume driver to call method with correct arguments Result: Clone from snapshot now works for ThinLVM volumes
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:18:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1210853 None None None Never
OpenStack gerrit 41262 None None None Never
OpenStack gerrit 41274 None None None Never

  None (edit)
Description Eric Harney 2013-08-10 18:59:34 EDT
$ cinder create --snapshot-id 0679dfdf-f95c-4af7-931e-b1ac1eb2c66d 1

results in

TRACE cinder.volume.flows.create_volume Traceback (most recent call last):
TRACE cinder.volume.flows.create_volume File "/opt/stack/cinder/cinder/taskflow/patterns/linear_flow.py", line 172, in run_it
TRACE cinder.volume.flows.create_volume result = runner(context, *args, **kwargs)
TRACE cinder.volume.flows.create_volume File "/opt/stack/cinder/cinder/taskflow/utils.py", line 260, in __call__
TRACE cinder.volume.flows.create_volume self.result = self.task(*args, **kwargs)
TRACE cinder.volume.flows.create_volume File "/opt/stack/cinder/cinder/volume/flows/create_volume.py", line 1383, in __call__
TRACE cinder.volume.flows.create_volume **volume_spec)
TRACE cinder.volume.flows.create_volume File "/opt/stack/cinder/cinder/volume/flows/create_volume.py", line 1159, in _create_from_snapshot
TRACE cinder.volume.flows.create_volume snapshot_ref)
TRACE cinder.volume.flows.create_volume File "/opt/stack/cinder/cinder/volume/drivers/lvm.py", line 140, in create_volume_from_snapshot
TRACE cinder.volume.flows.create_volume self._create_volume(volume['name'], self._sizestr(volume['size']))
TRACE cinder.volume.flows.create_volume TypeError: _create_volume() takes exactly 2 arguments (3 given)
TRACE cinder.volume.flows.create_volume
Comment 6 Giulio Fidente 2013-12-03 11:18:33 EST
the incorrect args issue was verified using:
openstack-cinder-2013.2-3.el6ost.noarch
Comment 9 errata-xmlrpc 2013-12-19 19:18:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.