Bug 995823 - SELinux is preventing /home/partzy/.local/share/Steam/SteamApps/common/dota 2 beta/dota_linux from using the 'execheap' accesses on a process.
SELinux is preventing /home/partzy/.local/share/Steam/SteamApps/common/dota 2...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2965a1f7cfd51103b0a7557b55a...
:
: 1203698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 06:36 EDT by ocgroza
Modified: 2015-03-19 16:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 10:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ocgroza 2013-08-11 06:36:51 EDT
Description of problem:
I started dota2 application...
SELinux is preventing /home/partzy/.local/share/Steam/SteamApps/common/dota 2 beta/dota_linux from using the 'execheap' accesses on a process.

*****  Plugin allow_execheap (53.1 confidence) suggests  *********************

If you do not think /home/partzy/.local/share/Steam/SteamApps/common/dota 2 beta/dota_linux should need to map heap memory that is both writable and executable.
Then you need to report a bug. This is a potentially dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests  *******************

If you want to allow selinuxuser to execheap
Then you must tell SELinux about this by enabling the 'selinuxuser_execheap' boolean.
You can read 'None' man page for more details.
Do
setsebool -P selinuxuser_execheap 1

*****  Plugin catchall (5.76 confidence) suggests  ***************************

If you believe that dota_linux should be allowed execheap access on processes labeled unconfined_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dota_linux /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ process ]
Source                        dota_linux
Source Path                   /home/partzy/.local/share/Steam/SteamApps/common/d
                              ota 2 beta/dota_linux
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.5-201.fc19.x86_64 #1 SMP Wed
                              Aug 7 16:25:24 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-08-11 13:29:59 MSK
Last Seen                     2013-08-11 13:32:53 MSK
Local ID                      f81e9297-08f8-4a22-8416-dcf331a1f092

Raw Audit Messages
type=AVC msg=audit(1376213573.402:518): avc:  denied  { execheap } for  pid=4510 comm="dota_linux" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1376213573.402:518): arch=i386 syscall=capget success=no exit=EACCES a0=21a8c000 a1=15000 a2=7 a3=ffb993ec items=0 ppid=4507 pid=4510 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=dota_linux exe=2F686F6D652F706172747A792F2E6C6F63616C2F73686172652F537465616D2F537465616D417070732F636F6D6D6F6E2F646F7461203220626574612F646F74615F6C696E7578 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: dota_linux,unconfined_t,unconfined_t,process,execheap

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.5-201.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-08-12 10:06:07 EDT
The alert told you what to do, although this is considered a dangerous access.  I would complain to Steam that they should fix their code.

*****  Plugin allow_execheap (53.1 confidence) suggests  *********************

If you do not think /home/partzy/.local/share/Steam/SteamApps/common/dota 2 beta/dota_linux should need to map heap memory that is both writable and executable.
Then you need to report a bug. This is a potentially dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests  *******************

If you want to allow selinuxuser to execheap
Then you must tell SELinux about this by enabling the 'selinuxuser_execheap' boolean.
You can read 'None' man page for more details.
Do
setsebool -P selinuxuser_execheap 1
Comment 2 Daniel Walsh 2015-03-19 16:05:54 EDT
*** Bug 1203698 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.