Bug 995838 - [patch] add missing Russian Legacy layout
[patch] add missing Russian Legacy layout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-table-cyrillic (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 08:43 EDT by Stas Sergeev
Modified: 2014-08-08 04:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-table-others-1.3.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-08 04:38:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add missing layout (5.57 KB, text/plain)
2013-08-11 08:43 EDT, Stas Sergeev
no flags Details
fix for rustrad (955 bytes, patch)
2013-08-11 08:44 EDT, Stas Sergeev
no flags Details | Diff
add missing layout (5.60 KB, patch)
2013-08-11 13:33 EDT, Stas Sergeev
no flags Details | Diff

  None (edit)
Description Stas Sergeev 2013-08-11 08:43:50 EDT
Created attachment 785389 [details]
add missing layout

Description of problem:
Not all tables of xkeyboard-config are available for ibus.
Russian Legacy is missing, for instance.

Version-Release number of selected component (if applicable):
ibus-table-cyrillic-1.3.0.20130204

How reproducible:
Easily

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Attaching the patch to add one.
Comment 1 Stas Sergeev 2013-08-11 08:44:29 EDT
Created attachment 785390 [details]
fix for rustrad
Comment 2 Stas Sergeev 2013-08-11 13:33:58 EDT
Created attachment 785433 [details]
add missing layout
Comment 3 Mike FABIAN 2014-07-24 06:41:13 EDT
(In reply to Stas Sergeev from comment #1)
> Created attachment 785390 [details]
> fix for rustrad

$ cat ~/Downloads/*rustra*
From d4ffbdf3d71ea7ba65adcf20b30c80ffb067ba88 Mon Sep 17 00:00:00 2001
From: Stas Sergeev <stsp@users.sourceforge.net>
Date: Sun, 11 Aug 2013 15:49:42 +0400
Subject: [PATCH 1/2] fix typo rustran->rustrad

---
 configure.ac | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index 26e19a6..00e6ab4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,11 +64,11 @@ AC_ARG_ENABLE([translitua],
 AM_CONDITIONAL([IBUS_TABLE_BUILD_TRANSLITUA],[test x"$enable_translitua" != x"no"])
 
 AC_ARG_ENABLE([rustrad],
-    [AC_HELP_STRING([--enable-rustran],
+    [AC_HELP_STRING([--enable-rustrad],
         [Generate Russian Traditional Engine])], ,
     [enable_rustrad=yes])
 
-AM_CONDITIONAL([IBUS_TABLE_BUILD_RUSTRAD],[test x"$enable_rustran" != x"no"])
+AM_CONDITIONAL([IBUS_TABLE_BUILD_RUSTRAD],[test x"$enable_rustrad" != x"no"])
 
 AC_ARG_ENABLE([yawerty],
     [AC_HELP_STRING([--enable-yawerty],
-- 
1.8.3.1

I cannot see any “rustran” in:

https://github.com/moebiuscurve/ibus-table-others/blob/master/configure.ac

only “rustrad”.

So this problem seems to be fixed already.

Git blame tells me that it has never been changed since this
repository was started, i.e. never changed since:

commit 5f51d48b502c9a23f5187b22850f23945a80ab12
Author: Naveen Kumar <nkumar@redhat.com>
Date:   Thu Sep 2 15:39:31 2010 +0530

    bulk commiting ibus-table-others files from kaio

What repository were you using for your patch?
Comment 4 Mike FABIAN 2014-07-24 06:45:22 EDT
(In reply to Stas Sergeev from comment #2)
> Created attachment 785433 [details]
> add missing layout

This layout not included yet, checking ...
Comment 5 Fedora Update System 2014-07-28 14:49:03 EDT
ibus-table-others-1.3.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-table-others-1.3.2-2.fc19
Comment 6 Fedora Update System 2014-07-28 14:49:41 EDT
ibus-table-others-1.3.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-table-others-1.3.2-2.fc20
Comment 8 Fedora Update System 2014-07-30 02:57:00 EDT
Package ibus-table-others-1.3.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-table-others-1.3.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8969/ibus-table-others-1.3.2-2.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-08-08 04:38:40 EDT
ibus-table-others-1.3.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-08-08 04:39:15 EDT
ibus-table-others-1.3.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.