Bug 995877 - SELinux is preventing /usr/sbin/httpd from 'getattr' accesses on the directory /var/log/zoneminder.
SELinux is preventing /usr/sbin/httpd from 'getattr' accesses on the director...
Status: CLOSED DUPLICATE of bug 995768
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:da553a83b8183d258642173c958...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 14:34 EDT by Allen
Modified: 2013-08-12 10:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 10:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen 2013-08-11 14:34:17 EDT
Description of problem:
SELinux is preventing /usr/sbin/httpd from 'getattr' accesses on the directory /var/log/zoneminder.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that httpd should be allowed getattr access on the zoneminder directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /usr/sbin/httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                system_u:object_r:zoneminder_log_t:s0
Target Objects                /var/log/zoneminder [ dir ]
Source                        /usr/sbin/httpd
Source Path                   /usr/sbin/httpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           httpd-2.4.6-2.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-300.fc19.x86_64 #1 SMP Tue
                              Jul 30 11:29:05 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-11 10:10:52 PDT
Last Seen                     2013-08-11 10:10:52 PDT
Local ID                      0938c016-cdc3-4aa4-9141-55edb74c411f

Raw Audit Messages
type=AVC msg=audit(1376241052.832:43690): avc:  denied  { getattr } for  pid=19797 comm="/usr/sbin/httpd" path="/var/log/zoneminder" dev="dm-0" ino=1970617 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:zoneminder_log_t:s0 tclass=dir


type=SYSCALL msg=audit(1376241052.832:43690): arch=x86_64 syscall=lstat success=yes exit=0 a0=7fff079d0740 a1=7fff079d04b0 a2=7fff079d04b0 a3=676f6c2e706870 items=0 ppid=19791 pid=19797 auid=4294967295 uid=48 gid=486 euid=48 suid=48 fsuid=48 egid=486 sgid=486 fsgid=486 ses=4294967295 tty=(none) comm=/usr/sbin/httpd exe=/usr/sbin/httpd subj=system_u:system_r:httpd_t:s0 key=(null)

Hash: /usr/sbin/httpd,httpd_t,zoneminder_log_t,dir,getattr

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.5-201.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-08-12 10:45:05 EDT

*** This bug has been marked as a duplicate of bug 995768 ***

Note You need to log in before you can comment on or make changes to this bug.