Bug 995891 - vsftpd update breaks package scriptlets
vsftpd update breaks package scriptlets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 17:04 EDT by Michal Jaegermann
Modified: 2014-11-09 17:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 16:35:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2013-08-11 17:04:45 EDT
Description of problem:

vsftpd-3.0.2-4.fc20 package scriplets look like this:


postinstall scriptlet (using /bin/sh):
%systemd_post vsftpd.service
preuninstall scriptlet (using /bin/sh):
%systemd_preun vsftpd.service
postuninstall scriptlet (using /bin/sh):
%systemd_postun_with_restart vsftpd.service

Not very surprisingly this results in the following:

/var/tmp/rpm-tmp.zfGqRn: line 1: fg: no job control
warning: %post(vsftpd-3.0.2-4.fc20.x86_64) scriptlet failed, exit status 1

Moreover, since postuninstall scriptlet is affected as well, on the next update it will fail and one will end up with duplicates as 
vsftpd-3.0.2-4.fc20 will be not removed (and apparently there is no other way to remove such duplicate as with 'rpm -e --no-scripts ...).

Version-Release number of selected component (if applicable):
vsftpd-3.0.2-4.fc20

Additional info:
See also bug 983760 (which already lingers way too long).
Comment 1 Jiri Skala 2013-08-15 16:35:17 EDT
I've committed changes inclusive 'BuildRequires: systemd' recommended in BZ#983760 (comments #7 & #11). If the difficulties persists, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.