Bug 995910 - Server internal error when push type is both
Server internal error when push type is both
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Persistence (Show other bugs)
3.0
Unspecified Linux
unspecified Severity high
: ---
: 3.0
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-11 20:38 EDT by Patrick Huang
Modified: 2013-11-26 22:36 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.1-SNAPSHOT (20130823-1233)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:23:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample project folder (1.74 MB, application/octet-stream)
2013-08-11 20:39 EDT, Patrick Huang
no flags Details

  None (edit)
Description Patrick Huang 2013-08-11 20:38:10 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31
Build Identifier: 

When pushing file with large amount of text flows (i.e. freeciv - 7265 messages),
translation push will fail near the end with server internal error:
23:54:04,829 ERROR [org.zanata.process.AsynchronousExecutor] (DefaultQuartzScheduler_Worker-1) Exception with long running process: Error during translation.: org.zanata.ex
ception.ZanataServiceException: Error during translation.
        at org.zanata.service.impl.TranslationServiceImpl.translateAllInDoc(TranslationServiceImpl.java:647) [classes:]
Caused by: java.lang.IllegalStateException: Transaction begin not detected, try installing transaction:ejb-transaction in components.xml
        at org.jboss.seam.transaction.SeSynchronizations.registerSynchronization(SeSynchronizations.java:55) [jboss-seam-2.3.0.Final.jar:2.3.0.Final]
Caused by: java.lang.IllegalStateException: Transaction begin not detected, try installing transaction:ejb-transaction in components.xml
        at org.jboss.seam.transaction.SeSynchronizations.registerSynchronization(SeSynchronizations.java:55) [jboss-seam-2.3.0.Final.jar:2.3.0.Final]

Reproducible: Always

Steps to Reproduce:
1. Use project freeciv as example and create NEW version
2. Make sure there is one locale is fully translated and include this in zanata.xml
3. mvn zanata:push -Dzanata.pushType=both -e
Actual Results:  
error occur during translation push

Expected Results:  
Successfully pushed source and target

Sample project file will be included as attachment
Comment 1 Patrick Huang 2013-08-11 20:39:59 EDT
Created attachment 785491 [details]
Sample project folder
Comment 2 Patrick Huang 2013-08-11 20:41:52 EDT
It seems to only happen for first push. If push failed and re-push again it will work. I think that's because merge type auto will detect most of the text flow hasn't changed.
Comment 3 Patrick Huang 2013-08-11 21:54:05 EDT
There are a lot of warning messages prior the ERROR stacktrace:
WARN  [org.zanata.service.impl.ActivityServiceImpl] (DefaultQuartzScheduler_Worker-8) Unable to log activity. One or more of the information is null: actor-null, context-HProjectIteration(super=SlugEntityBase(super=HProjectIteration@a1987bd4[id=11,versionNum=0], slug=master), project=HProject(super=SlugEntityBase(super=HProject@a0fe2d95[id=10,versionNum=0], slug=Tar), name=tar)), activityType-UPDATE_TRANSLATION
Comment 4 Patrick Huang 2013-08-11 21:55:37 EDT
Doesn't seem to relate to file size. Tried with GNU tar which is a normal sized project and same error happened.
Comment 5 Carlos Munoz 2013-08-12 02:42:22 EDT
Corrected an event being thrown in an incorrect manner.

See:
https://github.com/zanata/zanata-server/pull/116
Comment 6 Ding-Yi Chen 2013-08-23 02:01:15 EDT
VERIFIED with Zanata version 3.1-SNAPSHOT (20130823-1233)
Comment 7 Sean Flanigan 2013-11-26 22:13:41 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 8 Sean Flanigan 2013-11-26 22:15:38 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 9 Sean Flanigan 2013-11-26 22:19:08 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 10 Sean Flanigan 2013-11-26 22:23:32 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 11 Sean Flanigan 2013-11-26 22:33:48 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 12 Sean Flanigan 2013-11-26 22:36:03 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.