Bug 996023 - Designer complains about missing BPMNDI information which is not missing
Designer complains about missing BPMNDI information which is not missing
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 04:56 EDT by Radovan Synek
Modified: 2014-08-06 16:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full stacktrace (5.29 KB, text/x-log)
2013-08-12 04:56 EDT, Radovan Synek
no flags Details
process definition (6.96 KB, application/xml)
2013-08-12 04:57 EDT, Radovan Synek
no flags Details
working process definition with target namespace (2.87 KB, application/xml)
2013-08-15 08:23 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-08-12 04:56:47 EDT
Created attachment 785613 [details]
full stacktrace

Description of problem:
Designer fails to import process definition (originally created in Eclipse editor shipped with BRMS 5.3), "Could not find BPMNDI information" appears in server log, although the definition has BPMNDI elements with correct references to BPMN elements.

See the attached stacktrace and process definition.

Version-Release number of selected component (if applicable):
community 6.0.0.CR1

Steps to Reproduce:
1. start Business Central
2. create / open some process definition
3. import attached definition
Comment 1 Radovan Synek 2013-08-12 04:57:34 EDT
Created attachment 785614 [details]
process definition
Comment 2 Tihomir Surdilovic 2013-08-12 10:32:09 EDT
In your attachment BPMN2 remove

targetNamespace="http://www.jboss.org/drools"

and the process will import fine. This is not a Designer issue.
Comment 3 Radovan Synek 2013-08-13 03:59:58 EDT
(In reply to Tihomir Surdilovic from comment #2)
> In your attachment BPMN2 remove
> 
> targetNamespace="http://www.jboss.org/drools"
> 
> and the process will import fine. This is not a Designer issue.

Hello Tiho,

I am not sure if targetNamespace should cause this issue. The process definition I provided can be opened in Eclipse editor just fine. I have also checked the definition with this online validation tool [1] and again, no problems. Even if there is a problem with target namespace, the error message "Could not find BPMNDI information" is misleading.

[1] http://www.webratio.com/bpmnValidation/home.do
Comment 4 Tihomir Surdilovic 2013-08-13 11:12:13 EDT
I'm not sure what to do here. The targetnamespace is incorrect. The message is what the eclipse bpmn2 parser gives, not something set by designer itself.
Comment 5 Marek Baluch 2013-08-13 15:02:20 EDT
Tiho,

the web designer uses the eclipse bpmn2 API for validation? If so then this is a bug in the eclipse editor not in the web designer. We will change the component an reassign if need be.

Before we (myself) do so I would like to ask one last question (I don't want this issue to become a ping-pong match). Is the validation in the web designer based on the classes belonging to this project -> http://www.eclipse.org/bpmn2-modeler/ ? ... or is it the old modeler which was shipped with BRMS 5.3?

Thanks!
@M
Comment 6 Marek Baluch 2013-08-14 06:19:58 EDT
Tiho,

which version are you using? I tried to open the process definition in the BPMN2 Eclipse designer (nightly build from yesterday) and I see only "Expression and Language must not be blank" errors.

@M
Comment 7 Tihomir Surdilovic 2013-08-15 07:50:34 EDT
I think the talk should be more about how we want designer to be able to open bpmn2 files with incorrect targetnamespace definitions. I don't see this as a bug and there is a simple "fix" for it to just remove one attribute in the bpmn2. 

Will look into having designer remove incorrect targetnamespace defined.
Comment 8 Radovan Synek 2013-08-15 08:23:10 EDT
Created attachment 786927 [details]
working process definition with target namespace
Comment 9 Radovan Synek 2013-08-15 08:32:23 EDT
Tiho,

I am still not sure the targetnamespace is the (only) root cause - see the last attachment, there is a process definition containing a targetnamespace with the same value and Designer imports this definition without any problem.

Anyway, I cannot accept "Could not find BPMNDI information" as appropriate error message for issue which as it seems is not connected with BPMNDI elements at all.
Comment 14 Kris Verlaenen 2013-10-10 19:57:50 EDT
Tiho, not sure the targetNamespace is incorrect, if you look at the BPMN2 spec itself, there are various examples where the targetNamespace is set to something example-specific, so I believe this should be allowed.  Could you elaborate why it would be incorrect?

It's unclear to me though why or how the targetNamespace would be interacting with find bpmndi information.

The Eclipse BPMN2 Modeler is also using the Eclipse BPMN2 meta-model and doesn't seem to have issues opening the file.  Since the editor also sets the targetNamespace, being able to open a process with targetNamespace set would be required.
Comment 15 Tihomir Surdilovic 2013-10-15 11:30:08 EDT
fixed
Comment 16 Radovan Synek 2013-12-03 10:21:55 EST
Verified on BPMS-6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.