Bug 996054 - KDE "lock screen" behaves erratically on dual-head laptop (NVIDIA Corporation G96 [GeForce 9600M GT])
KDE "lock screen" behaves erratically on dual-head laptop (NVIDIA Corporation...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 06:37 EDT by David Tonhofer
Modified: 2014-02-05 17:16 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 17:16:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The displays in the configurator (97.96 KB, image/png)
2013-08-12 09:56 EDT, David Tonhofer
no flags Details

  None (edit)
Description David Tonhofer 2013-08-12 06:37:57 EDT
Description of problem:
=======================

(Unsure whether kde-workspace component)

Preambule:
-----------

In KDE with a laptop in "dual-head" mode.

Already, KDE is confused in managed the two display. There is a large main desktop display (LVDS1) and a smaller screen (VGA1) to its left. I need to reconfigure it every time the laptop gets restarted as KDE keeps falling back to the default "VGA1 clone of LVDS1" instead of "VGA1 left of LVDS1", in spite of "save as default". Additionally, primary output is "LVDS1" but KDE dialogs open on "VGA1" (this will be a problem later, you will see)

See attachment for setup in in System Settings.

Problem:
---------

"Lock the screen" (settings are "Desktop Widgets", not "Simple Locker" or "Screen Saver"). Technically, this seems to consist in moving the background image to the front, with an unlock widget on the top right. This has the additional problem that the unlock widget has a "settings" line via which you can traverse the file system hunting for images in spite of the screen being technically locked. But that's by the by.

After some time, displays are powered down. 

When reactivating, the LVSD1 displays the locked screen but VGA1 stays black (it is not down as the mouse can move around in it). There is no way to enter the unlock password! I suppose the unlock dialog is in VGA1 and cannot be seen (I have tried to blindly access it but to no avail). Unfortunately there is no screensaver process to kill over the console (or is there?), so I have to reboot the laptop.

This is bad, the unlock dialog should be on LVSD1 or VGA1 should be mad non-black.

Additional problem:
-------------------

Goin into "Screen Locker System Settings" and trying to test it fails abysmally as the background images is moved in front in LVSD1 but it becomes impossible to unlock (no unlock dialog is ever shown). VGA1 stays visible and one can move the mouse (as well as the windows), but the keyboard entry goes nowhere. So I have to reboot the laptop.

I will try what happens with "simple locker"


Version-Release number of selected component (if applicable):
-------------------------------------------------------------

kde-workspace-4.10.5-3.fc18.x86_64

How reproducible:
-----------------

Always
Comment 1 David Tonhofer 2013-08-12 06:39:14 EDT
"Simple Locker" is nice & sweet, same display on both displays.
Comment 2 David Tonhofer 2013-08-12 06:41:10 EDT
"Screensaver" works too, same display on both displays (though the dialog is not the same, one can for example type in a password in one display while the dialog on the other display is grayed out for a cooldown period after a wrong entry)
Comment 3 Martin Bříza 2013-08-12 08:50:27 EDT
I'm not sure about the lockscreen issue in particular but you can solve at least the screen configuration getting lost issue - please try using kscreen for screen management.
Comment 4 David Tonhofer 2013-08-12 09:56:43 EDT
Created attachment 785693 [details]
The displays in the configurator
Comment 5 David Tonhofer 2013-08-12 09:57:59 EDT
Thanks Martin.

Isn't KScreen for Fedora 19 though?
Comment 6 Rex Dieter 2013-08-12 10:00:31 EDT
While kscreen was a f19 feature (and installed by default), it is also available for f18 (as a kind of tech-preview).
Comment 7 Rex Dieter 2013-08-12 10:01:29 EDT
just make sure to restart your kde session after installing kscreen (it takes over functionality of the older krandrtray-based stuff).
Comment 8 David Tonhofer 2013-08-13 03:18:43 EDT
I ran

"yum install kscreen"

and now have kscreen-1.0.1-1.fc18.x86_64

The display come up correctly now. Great stuff.

(kscreen-console seems to hang after printing display details - oh well)
Comment 9 Martin Bříza 2013-08-13 07:34:36 EDT
It's hanging just in general sense - it waits for randr events to occur and prints information about them.
Comment 10 Fedora End Of Life 2013-12-21 09:28:05 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2014-02-05 17:16:20 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.