Bug 996063 - Fileop tests fail on smb mount
Fileop tests fail on smb mount
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susant Kumar Palai
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 06:52 EDT by Poornima G
Modified: 2014-04-17 07:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:45:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Poornima G 2013-08-12 06:52:42 EDT
Description of problem:
Fileop is failing on a 6x2 distributed replicate volume on smb mount in a ctdb setup.

Version-Release number of selected component (if applicable):

[root@dhcp159-205 glusterfs]# rpm -qa | grep glusterfs
glusterfs-devel-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-server-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta3-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.12rhs.beta3-1.el6rhs.x86_64


How reproducible:
I tried three times and it failed.

Steps to Reproduce:
1. create a ctdb setup.
2. create a dis-rep volume and do a cifs mount on the client with virtual ip corresponding to the physical ip on which the volume is created.
3. From the mount point run fileop.

Actual results:
Fileop failed .

Expected results:
Fileop should pass.

Additional info:
For the first time fileop ran for ~1 hour an then failed.
Second time for about 2 hours
Third time it ran for almost 4 hours and failed.
Comment 1 Anand Avati 2013-08-12 07:14:25 EDT
REVIEW: http://review.gluster.org/5576 (libgfapi : Fix for hardlink creation on CIFS mount) posted (#1) for review on master by susant palai (spalai@redhat.com)
Comment 2 Anand Avati 2013-08-12 07:31:32 EDT
REVIEW: http://review.gluster.org/5576 (libgfapi : Fix for hardlink creation on SMB mount) posted (#2) for review on master by susant palai (spalai@redhat.com)
Comment 3 Anand Avati 2013-08-12 09:00:33 EDT
REVIEW: http://review.gluster.org/5576 (libgfapi : Fix for hardlink creation on SMB mount) posted (#3) for review on master by susant palai (spalai@redhat.com)
Comment 4 Anand Avati 2013-08-12 09:19:54 EDT
REVIEW: http://review.gluster.org/5576 (libgfapi : Fix for hardlink creation on SMB mount) posted (#4) for review on master by susant palai (spalai@redhat.com)
Comment 5 Anand Avati 2013-08-12 13:44:36 EDT
REVIEW: http://review.gluster.org/5576 (libgfapi : Fix for hardlink creation on SMB mount) posted (#5) for review on master by Anand Avati (avati@redhat.com)
Comment 6 Anand Avati 2013-08-12 16:52:37 EDT
REVIEW: http://review.gluster.org/5576 (libgfapi : Fix for hardlink creation on SMB mount) posted (#6) for review on master by Anand Avati (avati@redhat.com)
Comment 7 Anand Avati 2013-08-13 12:00:40 EDT
COMMIT: http://review.gluster.org/5576 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit a78f7dcddbc3d2048a184b7f4f45a63586eb5580
Author: Anand Avati <avati@redhat.com>
Date:   Fri Aug 9 11:12:29 2013 -0700

    libgfapi : Fix for hardlink creation on SMB mount
    
    Previously the inode of the hard link was left uninitialised hence
    glfs_loc_link() used to fail with invalid parameter.Since inode is
    same for both the files in hard link creation,   updated the inode
    field of hard link to be same as that of the original file.
    
    Original-author: susant palai <spalai@redhat.com>
    Change-Id: Ifd6439867d982524a7b48bf3f6add6e844b3c4c1
    BUG: 996063
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5576
    Tested-by: susant palai <spalai@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Anand Avati 2013-09-09 20:55:40 EDT
REVIEW: http://review.gluster.org/5882 (libgfapi : Fix for hardlink creation on SMB mount) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 9 Anand Avati 2013-09-09 21:09:04 EDT
REVIEW: http://review.gluster.org/5882 (libgfapi : Fix for hardlink creation on SMB mount) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 10 Anand Avati 2013-09-10 04:24:41 EDT
COMMIT: http://review.gluster.org/5882 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 77a7ae0fbf5bf1a0eaa2d18a31bd0c6ef1913ef8
Author: Anand Avati <avati@redhat.com>
Date:   Fri Aug 9 11:12:29 2013 -0700

    libgfapi : Fix for hardlink creation on SMB mount
    
    Previously the inode of the hard link was left uninitialised hence
    glfs_loc_link() used to fail with invalid parameter.Since inode is
    same for both the files in hard link creation,   updated the inode
    field of hard link to be same as that of the original file.
    
    Change-Id: Ifd6439867d982524a7b48bf3f6add6e844b3c4c1
    BUG: 996063
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5882
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 11 Niels de Vos 2014-04-17 07:45:43 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.