Bug 996086 - dependency rubygem(psych) pulls broken package rubygem-psych, obvious workarounds unworkable
dependency rubygem(psych) pulls broken package rubygem-psych, obvious workaro...
Status: CLOSED DUPLICATE of bug 988490
Product: Fedora
Classification: Fedora
Component: rubygems (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 07:37 EDT by Paul DeStefano
Modified: 2013-08-18 22:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 22:14:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul DeStefano 2013-08-12 07:37:44 EDT
Description of problem:
Cannot have ruby without prelink errors or vice-versa.

After upgrade to F19, I had two seemingly unrelated problems that were both the result of broken package rubygem-psych.  The first problem was Bug 995876.  (At least I think that bug is caused by a bad library in this package.)  To fix the problem I removed rubygem-psych, but that lead back to package ruby and the whole system had to be uninstalled.

I didn't remember that a VIM extension, command-t, requires ruby and so I was shocked and confused by Bug 995951.


Version-Release number of selected component (if applicable):
rubygems-2.0.5-100.fc19.noarch
rubygem-psych-2.0.0-14.fc19.x86_64

How reproducible:
On every install of ruby package

Steps to Reproduce:
1. install ruby
2. 
3.

Actual results:
  Installing : rubygem-psych-2.0.0-14.fc19.x86_64                                                                                      9/9 
Error unpacking rpm package rubygem-psych-2.0.0-14.fc19.x86_64
error: unpacking of archive failed on file /usr/share/ruby/psych: cpio: rename


Expected results:
No errors

Additional info:
See Bug 995876 and Bug 995951.
Comment 1 Paul DeStefano 2013-08-12 07:45:27 EDT
Bah!  Sorry, need sleep.  Bug 995876 is not related.
Comment 2 Mamoru TASAKA 2013-08-18 22:14:28 EDT

*** This bug has been marked as a duplicate of bug 988490 ***

Note You need to log in before you can comment on or make changes to this bug.