Bug 996147 - RFE: Need API that allows a downed Compute Node to be removed after manual fencing and all guests that are on that node to be downed as well
RFE: Need API that allows a downed Compute Node to be removed after manual fe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
high Severity low
: ga
: 8.0 (Liberty)
Assigned To: Nikola Dipanov
Gabriel Szasz
: FutureFeature, MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 10:03 EDT by Perry Myers
Modified: 2016-04-26 16:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 15:42:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-08-12 10:03:42 EDT
Use case is the following:

Compute Node X is running a VM called foo
Compute Node dies (hardware failure, etc)

The datacenter admin might perform manual fencing of the physical node by toggling the power switch off or pulling the plug on it

But we need a way for the admin to tell Nova that "this compute node is now dead, I've manually fenced it".

That API should also then cascade and for every VM that was marked as running on that node, they should all be moved into the down state, since the host was confirmed as being shut off.  This would be an admin level API

There may be some existing APIs on the way in Havana that are close to providing this functionality.  ndipanov will do some investigation to see if any are close or do what is needed.  If not, a new blueprint or modification to an existing blueprint might be needed
Comment 2 Stephen Gordon 2016-01-28 15:42:24 EST
The mark host down API added in Liberty facilitates part of this requirement, the rest is handled via the Instance HA updates to the pacemaker configuration we deploy.

Note You need to log in before you can comment on or make changes to this bug.