This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 996151 - qcow2 corruption bug in cluster allocation code
qcow2 corruption bug in cluster allocation code
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: ZStream
: 901573 (view as bug list)
Depends On: 974617
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 10:11 EDT by Idith Tal-Kohen
Modified: 2014-02-17 18:18 EST (History)
19 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.355.el6_4.7
Doc Type: Bug Fix
Doc Text:
* Previously, a counter variable was not correctly reset when restarting an allocating request for disk images using the qcow2 format, which resulted in corruption of these disk images in the cluster allocation code in some cases. This update changes the way that the number of available clusters are counted in the qcow2 format, and qcow2 disks are no longer corrupted in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 04:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproduction - failed log (35.69 KB, text/plain)
2013-08-15 05:14 EDT, Qunfang Zhang
no flags Details
Verification - passed log (175.59 KB, text/plain)
2013-08-15 05:17 EDT, Qunfang Zhang
no flags Details

  None (edit)
Description Idith Tal-Kohen 2013-08-12 10:11:56 EDT
This bug has been copied from bug #974617 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 6 Qunfang Zhang 2013-08-15 05:13:58 EDT
Reproduced this issue on qemu-kvm-0.12.1.2-2.355.el6 at the first time attempt. Verified the bug with qemu-kvm-0.12.1.2-2.355.el6_4.7 for twice, all passed.

Steps:

0. Make sure host has 100GB+ free disk. 
1. Download 
http://people.canonical.com/~arges/lp1189926/lnv-382.tgz
2. Uncompress the lnv-382.tgz
3. ./create-disk
4. Modified "test-kvm" and replace command "kvm" to "/usr/libexec/qemu-kvm".
5. ./test-kvm


I will upload the attachment for detail logs for both reproduction (failed) and verification (passed) cases.
Comment 7 Qunfang Zhang 2013-08-15 05:14:58 EDT
Created attachment 786872 [details]
Reproduction - failed log
Comment 8 Qunfang Zhang 2013-08-15 05:17:08 EDT
Created attachment 786873 [details]
Verification - passed log
Comment 11 errata-xmlrpc 2013-08-27 04:04:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1175.html
Comment 12 Ayal Baron 2014-02-17 18:18:14 EST
*** Bug 901573 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.