Bug 996158 - Shim package does not get upgraded via yum or RPM.
Shim package does not get upgraded via yum or RPM.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: shim (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 10:23 EDT by jason
Modified: 2013-08-14 06:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 06:57:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jason 2013-08-12 10:23:19 EDT
Description of problem:

Shim package does not get installed via yum or RPM.


Version-Release number of selected component (if applicable):
  Upgrading from shim-0.2-4.4.fc19.x86_64 to shim-0.4-1.fc19.x86_64

How reproducible:
run yum update from a Fedora-Live-XFCE-x86_64-19-1.iso installation.

Steps to Reproduce:
1. Install Fedora from Fedora-Live-XFCE-x86_64-19-1.iso.
2. Run "yum update"

Actual results:
# yum update shim
Loaded plugins: langpacks
qemu-firmware-jenkins                                                                                                                          | 2.9 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package shim.x86_64 0:0.2-4.4.fc19 will be updated
---> Package shim.x86_64 0:0.4-1.fc19 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================================
 Package                              Arch                                   Version                                    Repository                               Size
======================================================================================================================================================================
Updating:
 shim                                 x86_64                                 0.4-1.fc19                                 updates                                 642 k

Transaction Summary
======================================================================================================================================================================
Upgrade  1 Package

Total download size: 642 k
Is this ok [y/d/N]: y
Downloading packages:
shim-0.4-1.fc19.x86_64.rpm                                                                                                                     | 642 kB  00:00:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : shim-0.4-1.fc19.x86_64                                                                                                                             1/2 
Error unpacking rpm package shim-0.4-1.fc19.x86_64
error: unpacking of archive failed: cpio: lstat
shim-0.2-4.4.fc19.x86_64 was supposed to be removed but is not!
  Verifying  : shim-0.2-4.4.fc19.x86_64                                                                                                                           1/2 
  Verifying  : shim-0.4-1.fc19.x86_64                                                                                                                             2/2 

Failed:
  shim.x86_64 0:0.2-4.4.fc19                                                         shim.x86_64 0:0.4-1.fc19                                                        

Complete!
#

Expected results:
shim updated from version shim.x86_64 0:0.2-4.4.fc19 to shim.x86_64 0:0.4-1.fc19

Additional info:
Comment 1 jason 2013-08-14 06:57:52 EDT
My efi boot partition was corrupt.  This is a not bug.

Note You need to log in before you can comment on or make changes to this bug.