Bug 996188 - removing "Monitoring" entitlement on "System Entitlements" page
removing "Monitoring" entitlement on "System Entitlements" page
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2013-08-12 11:27 EDT by Jan Hutař
Modified: 2017-06-08 11:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-08 11:17:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-08-12 11:27:32 EDT
Description of problem:
You are unable to add or remove Monitoring add-on entitlement on Overview -> Subscription Management -> System Entitlements. It is possible for Provisioning and when I have edited the form "Add-On Entitlement" and made it have ...value="monitoring_entitled"..., Monitoring entitlement was nicely added.


Version-Release number of selected component (if applicable):
spacewalk-java-2.0.2-15.el5sat


How reproducible:
always


Steps to Reproduce:
1. Go to Overview -> Subscription Management -> System Entitlements
2. Check some system
3. In "Add-On Entitlement" part of the form attempt to choose "Monitoring"
   and click either "Add" or "Remove" button


Actual results:
There is no Monitoring in the drop-down list


Expected results:
It should be there - mine use-case was: I wanted to activate with new certificate and rhn-satellite-activate complains I do not have monitoring in mine new cert although I have that entitlement used on few mine systems. So I want quickly remove that add-on entitlement from all systems which have it.


Additional info:
This does not work in Sat550 either so I vote for fixing post GA if it is worth it.
Comment 1 Jan Dobes 2013-09-12 03:29:34 EDT
I noticed this bug also when I created orgs with different available entitlements. In this menu is only one kind of addon entitlement even there are other possible entitlements. The offered entitlement shouldn't often be there because it has no available entitlements left.

In default admin-org there are more available types (not only one) but sometimes some entitlements are missing.

Note You need to log in before you can comment on or make changes to this bug.