Bug 996199 - maven-scm dont build with plexus-container-default 1.5.x
maven-scm dont build with plexus-container-default 1.5.x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-scm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 11:54 EDT by gil cattaneo
Modified: 2013-08-24 16:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: maven-scm-1.7-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-24 15:05:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gil cattaneo 2013-08-12 11:54:35 EDT
Description of problem:
maven-scm dont build with plexus-container-default 1.5.x

Version-Release number of selected component (if applicable):
1.7-9.fc20

How reproducible:
always

[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven SCM Client 1.7
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-remote-resources-plugin:1.4:process (default) @ maven-scm-client ---
[INFO] 
[INFO] --- plexus-component-metadata:1.5.5:merge-metadata (merge) @ maven-scm-client ---
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ maven-scm-client ---
[INFO] Using 'ISO-8859-1' encoding to copy filtered resources.
[INFO] Copying 1 resource
[INFO] Copying 5 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.0:compile (default-compile) @ maven-scm-client ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 1 source file to /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/target/classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/src/main/java/org/apache/maven/scm/client/cli/MavenScmCli.java:[40,33] package org.codehaus.plexus.embed does not exist
[ERROR] /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/src/main/java/org/apache/maven/scm/client/cli/MavenScmCli.java:[50,13] cannot find symbol
  symbol:   class Embedder
  location: class org.apache.maven.scm.client.cli.MavenScmCli
[ERROR] /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/src/main/java/org/apache/maven/scm/client/cli/MavenScmCli.java:[61,22] cannot find symbol
  symbol:   class Embedder
  location: class org.apache.maven.scm.client.cli.MavenScmCli
[INFO] 3 errors 
[INFO] -------------------------------------------------------------
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Skipping Maven SCM
[INFO] This project has been banned from the build due to previous failures.
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Maven SCM ......................................... SUCCESS [1.196s]
[INFO] Maven SCM API ..................................... SUCCESS [2.074s]
[INFO] Maven SCM Managers ................................ SUCCESS [0.027s]
[INFO] Maven SCM Manager for Plexus ...................... SUCCESS [0.799s]
[INFO] Maven SCM Test .................................... SUCCESS [0.427s]
[INFO] Maven SCM Providers ............................... SUCCESS [0.025s]
[INFO] Maven SCM AccuRev Provider ........................ SUCCESS [0.582s]
[INFO] Maven SCM Bazaar Provider ......................... SUCCESS [0.411s]
[INFO] Maven SCM Clearcase Provider ...................... SUCCESS [0.883s]
[INFO] Maven SCM CVS Provider - Parent ................... SUCCESS [0.025s]
[INFO] Maven SCM CVS Provider - Common library ........... SUCCESS [0.426s]
[INFO] Maven SCM CVS Provider - CVS Executable Impl. ..... SUCCESS [0.200s]
[INFO] Maven SCM CVS Provider TCK tests .................. SUCCESS [0.277s]
[INFO] Maven SCM Mercurial (Hg) Provider ................. SUCCESS [0.311s]
[INFO] Maven SCM Git Provider - Parent ................... SUCCESS [0.024s]
[INFO] Maven SCM Git Provider - Common library ........... SUCCESS [0.216s]
[INFO] Maven SCM Git Provider TCK Tests .................. SUCCESS [0.203s]
[INFO] Maven SCM Git Provider - Git Executable Impl. ..... SUCCESS [0.270s]
[INFO] Maven SCM Local Provider .......................... SUCCESS [0.241s]
[INFO] Maven SCM Perforce Provider ....................... SUCCESS [0.351s]
[INFO] Maven SCM Starteam Provider ....................... SUCCESS [0.341s]
[INFO] Maven SCM Subversion Provider - Parent ............ SUCCESS [0.042s]
[INFO] Maven SCM Subversion Provider - Common library .... SUCCESS [0.171s]
[INFO] Maven SCM Subversion Provider - SVN Executable Impl.  SUCCESS [0.310s]
[INFO] Maven SCM Synergy Provider ........................ SUCCESS [0.239s]
[INFO] Maven SCM Visual Source Safe Provider ............. SUCCESS [0.444s]
[INFO] Maven SCM TFS Provider ............................ SUCCESS [0.176s]
[INFO] Maven SCM Jazz/Rational Team Concert Provider ..... SUCCESS [0.200s]
[INFO] Maven SCM Standard Providers ...................... SUCCESS [0.271s]
[INFO] Maven SCM Subversion Provider TCK Tests ........... SUCCESS [0.128s]
[INFO] Maven SCM Client .................................. FAILURE [0.434s]
[INFO] Maven SCM Plugin .................................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 14.126s
[INFO] Finished at: Mon Aug 12 17:40:48 CEST 2013
[INFO] Final Memory: 80M/342M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.0:compile (default-compile) on project maven-scm-client: Compilation failure: Compilation failure:
[ERROR] /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/src/main/java/org/apache/maven/scm/client/cli/MavenScmCli.java:[40,33] package org.codehaus.plexus.embed does not exist
[ERROR] /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/src/main/java/org/apache/maven/scm/client/cli/MavenScmCli.java:[50,13] cannot find symbol
[ERROR] symbol:   class Embedder
[ERROR] location: class org.apache.maven.scm.client.cli.MavenScmCli
[ERROR] /home/gil/rpmbuild/BUILD/maven-scm-1.7/maven-scm-client/src/main/java/org/apache/maven/scm/client/cli/MavenScmCli.java:[61,22] cannot find symbol
[ERROR] symbol:   class Embedder
[ERROR] location: class org.apache.maven.scm.client.cli.MavenScmCli
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
[ERROR] 
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :maven-scm-client
errore: Stato d'uscita errato da /var/tmp/rpm-tmp.vdGrup (%build)
Comment 1 Mikolaj Izdebski 2013-08-12 11:59:41 EDT
Thanks for the report.
I confirm this.
Comment 2 Alexander Kurtakov 2013-08-12 12:04:00 EDT
For the record there is maven-scm 1.8.1
Comment 3 Mikolaj Izdebski 2013-08-12 12:09:46 EDT
I know.
I remember trying to sanitize this package, but it uses some ancient libraries, like old classworlds (pre-plexus-classworlds), old plexus-container etc.

I'll try to port it to recent versions of dependencies and upstream patches when I have a bit more time.
Comment 4 Mat Booth 2013-08-24 15:05:34 EDT
I added a small patch to port the SCM Client module to the new default plexus container. I will submit this patch upstream.

This should be fixed in latest build: maven-scm-1.7-10

https://koji.fedoraproject.org/koji/buildinfo?buildID=458801

You can test it by trying to invoke the SCM Client, for example here is the command to use the SCM Client to check out a Subversion repository:

java -cp $(build-classpath maven-scm/maven-scm-client maven-scm/maven-scm-api maven-scm/maven-scm-manager-plexus maven-scm/maven-scm-provider-svn-commons maven-scm/maven-scm-provider-svnexe plexus-containers/plexus-container-default plexus/classworlds plexus/utils guava xbean/xbean-reflect) org.apache.maven.scm.client.cli.MavenScmCli checkout working_copy scm:svn:http://svn.apache.org/repos/asf/subversion/trunk/
Comment 5 Mat Booth 2013-08-24 16:18:31 EDT
Patch submitted upstream:

http://jira.codehaus.org/browse/SCM-731

Note You need to log in before you can comment on or make changes to this bug.