Bug 996288 - sisu packages bad "obsoletes" make the whole collection unupgradable
sisu packages bad "obsoletes" make the whole collection unupgradable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sisu (Show other bugs)
rawhide
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 16:38 EDT by Michal Jaegermann
Modified: 2013-08-13 04:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.0.0-0.3.M4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 04:03:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2013-08-12 16:38:32 EDT
Description of problem:

A package sisu-inject-0.0.0-0.2.M4.fc20.noarch includes the following obsoletes:

sisu-bean < 1:0.0.0-0.2.M4.fc20
sisu-bean-binders < 1:0.0.0-0.2.M4.fc20
sisu-bean-containers < 1:0.0.0-0.2.M4.fc20
sisu-bean-converters < 1:0.0.0-0.2.M4.fc20
sisu-bean-inject < 1:0.0.0-0.2.M4.fc20
sisu-bean-locators < 1:0.0.0-0.2.M4.fc20
sisu-bean-reflect < 1:0.0.0-0.2.M4.fc20
sisu-bean-scanners < 1:0.0.0-0.2.M4.fc20
sisu-containers < 1:0.0.0-0.2.M4.fc20
sisu-inject-bean < 1:0.0.0-0.2.M4.fc20
sisu-inject-plexus < 1:0.0.0-0.2.M4.fc20
sisu-osgi-registry < 1:0.0.0-0.2.M4.fc20
sisu-parent < 1:0.0.0-0.2.M4.fc20
sisu-plexus-binders < 1:0.0.0-0.2.M4.fc20
sisu-plexus-converters < 1:0.0.0-0.2.M4.fc20
sisu-plexus-lifecycles < 1:0.0.0-0.2.M4.fc20
sisu-plexus-locators < 1:0.0.0-0.2.M4.fc20
sisu-plexus-metadata < 1:0.0.0-0.2.M4.fc20
sisu-plexus-scanners < 1:0.0.0-0.2.M4.fc20
sisu-plexus-shim < 1:0.0.0-0.2.M4.fc20
sisu-registries < 1:0.0.0-0.2.M4.fc20
sisu-spi-registry < 1:0.0.0-0.2.M4.fc20

So far so good BUT if some sisu packages were already installed (and they most likely were due to a bunch of dependencies) then an attempt to upgrade such installation bumps into the following:

---> Package sisu-bean.noarch 0:2.3.0-8.fc20 will be obsoleted
--> Processing Dependency: sisu-bean = 2.3.0-8.fc20 for package: sisu-2.3.0-8.fc20.noarch
---> Package sisu-bean-binders.noarch 0:2.3.0-8.fc20 will be obsoleted
--> Processing Dependency: sisu-bean-binders = 2.3.0-8.fc20 for package: sisu-2.3.0-8.fc20.noarch
....
and so on, and so on ....

The catch is that nothing obsoletes 'sisu' itself so after all dependency checks, and when --skip-broken flag is in use, one ends up with:

Skipped (dependency problems)  170 Packages

That "170 Packages" may vary depending what was already installed.  In my case all that stuff showed up in the past only due to assorted dependencies so in other cases this number can be even higher.

Version-Release number of selected component (if applicable):
sisu-0.0.0-0.2.M4.fc20

How reproducible:
on every update attempt

Additional info:
Running at this state 'yum remove sisu' succeeds and removes only this single package.  After that operation 'yum update', at least in my case, does not have anymore dependency problems and all these "170 Packages" can be upgraded.
Comment 1 Mikolaj Izdebski 2013-08-13 03:38:10 EDT
Fixed in sisu-0.0.0-0.3.M4
Comment 2 Mikolaj Izdebski 2013-08-13 04:03:03 EDT
I believe that this bug is fixed in sisu-0.0.0-0.3.M4,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=456353

Note You need to log in before you can comment on or make changes to this bug.