This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 996305 - webalizer -c option no longer works
webalizer -c option no longer works
Status: CLOSED DUPLICATE of bug 1382785
Product: Fedora
Classification: Fedora
Component: webalizer (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 18:17 EDT by Joel C Ewing
Modified: 2016-12-01 18:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:44:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel C Ewing 2013-08-12 18:17:50 EDT
Description of problem: 
Have a fairly conventionall 00webalizer cron.daily script to handle multiple webalizer runs specifying a different conf file via "-c" option for each run, where functional part of bash script is
...
for i in /etc/webalizer/*.conf
  do 
     /usr/bin/webalizer -Q -c $i     
  done
 
This worked under Fedora 17 and earlier releases, but under Fedora 19 (with the default /etc/webalizer.conf file renamed and the "-Q" replaced with "-v") webalizer produces the message:
"Error: Unable to open configuration file /etc/webalizer/webalizers.conf", where the indicated path and file is what was passed on the "-c" option, with similar failures for all other conf files in /etc/webalizer directory.  Other messages follow that confirm the intended output directory, history file, and hostname are not being used, proving that the intended conf while was indeed not processed.  The access attributes including SE context on the conf files in question are identical with those on the default installed /etc/webalizer.conf file.  Tried changing the script to change to directory /etc/webalizer and pass webalizer just the file name, but that failed with similar messages.  The only way I could get this to function was to copy each conf file in succession to the default webalizer conf files /etc/webalizer.conf and invoke webalizer without any "-c" option, as in
...
for i in /etc/webalizer/*.conf
  do 
     /bin/cp -f --preserve=timestamps $i /etc/webalizer.conf
     /usr/bin/webalizer -v 
  done



Version-Release number of selected component (if applicable):
webalizer-2.23-05


How reproducible: 100%


Steps to Reproduce:
1.Rename original /etc/webalizer.conf file
2.Create /etc/webalizer directory containing webalizer conf file(s) with unique names
3. Invoke webalizer from a cron script with 
for i in /etc/webalizer/*.conf
  do 
     /usr/bin/webalizer -Q -c $i     
  done

Actual results:
"Error: Unable to open configuration file <-c- option-filenamepath-here>"

Expected results:
Alternate conf file specifed in -c option should have been used as if it were in /etc/webalizer.conf and no "-c" option was specified.

Additional info:
I suspect this might be reproducible without using cron scripts, but since my objective was to get this working under cron and there might have been something significant with that environment, all my testing was in that environment.
Comment 1 Fedora Admin XMLRPC Client 2014-07-16 08:13:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora End Of Life 2015-01-09 14:25:42 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2015-02-17 11:44:27 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 4 Sergio Monteiro Basto 2016-12-01 18:57:06 EST
marking as duplicated of another selinux , if we fixed you will know.

*** This bug has been marked as a duplicate of bug 1382785 ***

Note You need to log in before you can comment on or make changes to this bug.