Bug 996349 - packaging in brew fails if no files in images dir
packaging in brew fails if no files in images dir
Status: CLOSED DUPLICATE of bug 995896
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-12 22:55 EDT by Laura Bailey
Modified: 2013-08-15 20:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 20:37:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Stephen Gordon 2013-08-13 08:06:58 EDT
Reproduced without Publican 3.1.5 involved at all (all commands run on a system with Publican 3.2.0 installed):

$ publican create --name TestBook
	Processing file en-US/Author_Group.xml -> en-US/Author_Group.xml
	Processing file en-US/Book_Info.xml -> en-US/Book_Info.xml
	Processing file en-US/Chapter.xml -> en-US/Chapter.xml
	Processing file en-US/Preface.xml -> en-US/Preface.xml
	Processing file en-US/Revision_History.xml -> en-US/Revision_History.xml
	Processing file en-US/TestBook.xml -> en-US/TestBook.xml
$ cd TestBook/
$ ls
en-US  publican.cfg
$ rm en-US/images/ -r
$ publican package
Running clean process to ensure stale content is not bundled in packages.
Clean: Removing tmp and publish directories.
Setting up en-US
	Processing file tmp/en-US/xml/Common_Content/Conventions.xml -> tmp/en-US/xml/Common_Content/Conventions.xml
	Processing file tmp/en-US/xml/Common_Content/Feedback.xml -> tmp/en-US/xml/Common_Content/Feedback.xml
	Processing file tmp/en-US/xml/Common_Content/Legal_Notice.xml -> tmp/en-US/xml/Common_Content/Legal_Notice.xml
	Processing file tmp/en-US/xml/Common_Content/Program_Listing.xml -> tmp/en-US/xml/Common_Content/Program_Listing.xml
	Processing file tmp/en-US/xml/Common_Content/Revision_History.xml -> tmp/en-US/xml/Common_Content/Revision_History.xml
	Processing file tmp/en-US/xml_tmp/Author_Group.xml -> tmp/en-US/xml/Author_Group.xml
	Processing file tmp/en-US/xml_tmp/Book_Info.xml -> tmp/en-US/xml/Book_Info.xml
	Processing file tmp/en-US/xml_tmp/Chapter.xml -> tmp/en-US/xml/Chapter.xml
	Processing file tmp/en-US/xml_tmp/Preface.xml -> tmp/en-US/xml/Preface.xml
	Processing file tmp/en-US/xml_tmp/Revision_History.xml -> tmp/en-US/xml/Revision_History.xml
	Processing file tmp/en-US/xml_tmp/TestBook.xml -> tmp/en-US/xml/TestBook.xml
	Using XML::LibXSLT on /usr/share/publican/xsl/web-spec.xsl
Wrote: /tmp/TestBook/tmp/rpm/Documentation-TestBook-0.1-web-en-US-0.0-0.fc18.src.rpm
$ rpmbuild --rebuild /tmp/TestBook/tmp/rpm/Documentation-TestBook-0.1-web-en-US-0.0-0.fc18.src.rpm
Installing /tmp/TestBook/tmp/rpm/Documentation-TestBook-0.1-web-en-US-0.0-0.fc18.src.rpm
Executing(%prep): /bin/sh -e /home/sgordon/rpmbuild/tmp/rpm-tmp.CTD5Z8
+ umask 022
+ cd /home/sgordon/rpmbuild/BUILD
+ cd /home/sgordon/rpmbuild/BUILD
+ rm -rf Documentation-TestBook-0.1-web-en-US-0.0
+ /usr/bin/gzip -dc /home/sgordon/rpmbuild/SOURCES/Documentation-TestBook-0.1-web-en-US-0.0-0.tgz
+ /usr/bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd Documentation-TestBook-0.1-web-en-US-0.0
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /home/sgordon/rpmbuild/tmp/rpm-tmp.r6CAek
+ umask 022
+ cd /home/sgordon/rpmbuild/BUILD
+ cd Documentation-TestBook-0.1-web-en-US-0.0
+ publican build --nocolours --embedtoc --formats=html,html-single,pdf,epub,html-desktop --langs=en-US --publish
WARNING: config key base_brand is not valid for this type of object, ignoring.
Setting up en-US
	Processing file tmp/en-US/xml/Common_Content/Conventions.xml -> tmp/en-US/xml/Common_Content/Conventions.xml
	Processing file tmp/en-US/xml/Common_Content/Feedback.xml -> tmp/en-US/xml/Common_Content/Feedback.xml
	Processing file tmp/en-US/xml/Common_Content/Legal_Notice.xml -> tmp/en-US/xml/Common_Content/Legal_Notice.xml
	Processing file tmp/en-US/xml/Common_Content/Program_Listing.xml -> tmp/en-US/xml/Common_Content/Program_Listing.xml
	Processing file tmp/en-US/xml/Common_Content/Revision_History.xml -> tmp/en-US/xml/Common_Content/Revision_History.xml
	Processing file tmp/en-US/xml_tmp/Author_Group.xml -> tmp/en-US/xml/Author_Group.xml
	Processing file tmp/en-US/xml_tmp/Book_Info.xml -> tmp/en-US/xml/Book_Info.xml
	Processing file tmp/en-US/xml_tmp/Chapter.xml -> tmp/en-US/xml/Chapter.xml
	Processing file tmp/en-US/xml_tmp/Preface.xml -> tmp/en-US/xml/Preface.xml
	Processing file tmp/en-US/xml_tmp/Revision_History.xml -> tmp/en-US/xml/Revision_History.xml
	Processing file tmp/en-US/xml_tmp/TestBook.xml -> tmp/en-US/xml/TestBook.xml
Beginning work on en-US
DTD Validation OK
	Starting html
	Using XML::LibXSLT on /usr/share/publican/xsl/html.xsl
Writing pr01s02.html for section
Writing pref-Documentation-TestBook-Preface.html for preface(pref-Documentation-TestBook-Preface)
Writing sect-Documentation-TestBook-Test_Chapter-Test_Section_2.html for section(sect-Documentation-TestBook-Test_Chapter-Test_Section_2)
Writing chap-Documentation-TestBook-Test_Chapter.html for chapter(chap-Documentation-TestBook-Test_Chapter)
Writing appe-Documentation-TestBook-Revision_History.html for appendix(appe-Documentation-TestBook-Revision_History)
Writing ix01.html for index
Writing index.html for book
Can not copy directory tmp/en-US/xml/images to tmp/en-US/html/images due to error:  at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 1788.
error: Bad exit status from /home/sgordon/rpmbuild/tmp/rpm-tmp.r6CAek (%build)


RPM build errors:
    Bad exit status from /home/sgordon/rpmbuild/tmp/rpm-tmp.r6CAek (%build)
Comment 6 Ruediger Landmann 2013-08-15 19:44:01 EDT

*** This bug has been marked as a duplicate of bug 995896 ***
Comment 7 Jeff Fearn 2013-08-15 20:37:36 EDT
oops

*** This bug has been marked as a duplicate of bug 995896 ***

Note You need to log in before you can comment on or make changes to this bug.