This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 996360 - Can't display the Hypervisor host in the sam after virt-who successfully sending esx host/guest mappings to SAM
Can't display the Hypervisor host in the sam after virt-who successfully send...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Tom McKay
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-13 00:00 EDT by Liushihui
Modified: 2013-10-01 07:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:18:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SAM log (106.75 KB, application/x-gzip)
2013-08-13 00:04 EDT, Liushihui
no flags Details

  None (edit)
Comment 1 Liushihui 2013-08-13 00:04:57 EDT
Created attachment 785961 [details]
SAM log
Comment 2 Tom McKay 2013-08-13 09:23:21 EDT
In step #5

5. Restart virt-who on Host1, then make Host1 registered to SAM 
#service virt-who restart
#subscription-manager register --username=admin --password=admin

Could you try a couple variations?

Variation 1:
# service virt-who restart
# subscription-manager register --username=admin --password=admin
# service virt-who status
? Is it running or has it exited?

Variation 2:
# subscription-manager register --username=admin --password=admin
# service virt-who restart
? Does the ESX host show up now?

Is this ESX accessible? I do not have a setup to actually test this. If the ESX is available, I would run virt-who on my system to see what is happening.

Running virt-who directly and not as a service might yield more debug information as well:
# virt-who -d --interval=10
Comment 5 Tom McKay 2013-08-15 15:57:35 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 6c385fd8723a445412fadf488b73ccca08c8e879
      https://github.com/Katello/katello/commit/6c385fd8723a445412fadf488b73ccca08c8e879
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-08-15 (Thu, 15 Aug 2013)
Comment 7 Bryan Kearney 2013-08-28 13:12:04 EDT
Lates build (Snap4) should contain these fixes. Please test on Snap4.
Comment 8 Liushihui 2013-09-02 06:30:25 EDT
Verified it on RHEL5.10-RC-1.3(20130829.2)-server-x86_64 against SAM-1.3.0-RHEL-6-snapshot4(20130829.1), see following test steps:

Version-Release number of selected component (if applicable):
subscription-manager-1.8.21-1.el5
python-rhsm-1.8.17-1.el5
virt-who-0.7-9.el5
katello-headpin-1.4.3-11.el6sam_splice.noarch
candlepin-0.8.24-1.el6sam.noarch

Verified steps:
1. Prepared one rhel5.10 hosts(Host1) which is running virt-who
2. Add Host2(ESX) to vclientvcenter
3. Config the virt-who on Host1 that in step1
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=10
VIRTWHO_ESX=1
VIRTWHO_ESX_OWNER=ACME_Corporation
VIRTWHO_ESX_ENV=Library
VIRTWHO_ESX_SERVER=10.66.79.4
VIRTWHO_ESX_USERNAME=administrator
VIRTWHO_ESX_PASSWORD=qwer1234P
5. Restart virt-who on Host1, then make Host1 registered to SAM 
#service virt-who restart
#subscription-manager register --username=admin --password=admin
6. In the host1, Check the virt-who report log in /var/log/rhsm/rhsm.log, the two ESX host consumer uuid is 44454c4c-4200-1034-8039-b8c04f503258
see as the following:
2013-08-12 23:41:07,365 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {[44454c4c-4200-1034-8039-b8c04f503258: [4216c590-b247-b5d2-22c0-fb1b6b665d57]}
7. Go to the sam server, Check the registered host, please see the SAM log in the attachment.
[root@samserv ~]# headpin -u admin -p admin system list --org=ACME_Corporation --environment=Library
--------------------------------------------------------------------------------------------------------------------------------------------
                                    Systems List For Environment [ Library ] in Org [ ACME_Corporation ]

Name                                 UUID                                 Environment Service Level Content View              
--------------------------------------------------------------------------------------------------------------------------------------------
44454c4c-4200-1034-8039-b8c04f503258 44454c4c-4200-1034-8039-b8c04f503258 Library                   Default Organization View 
esx-6.4-server-x86-64.nay.redhat.com 1a5a05a0-bc39-4e89-99d4-6842c8ec7109 Library                   Default Organization View 
hp-z220-05.qe.lab.eng.nay.redhat.com fe827c25-1b26-4bcd-93d9-3c507a98287e Library                   Default Organization View 

Result: It has display the hypervior, Both the name and uuid are "44454c4c-4200-1034-8039-b8c04f503258" 

As the result the same as the expected result, Therefore, Verified it on SAM-1.3.0-RHEL-6-snapshot4(20130829.1)
Comment 10 errata-xmlrpc 2013-10-01 07:18:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.