Bug 996388 - [Review Feature] "Confirm rejection" should work with only reviewer role
Summary: [Review Feature] "Confirm rejection" should work with only reviewer role
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.1
Assignee: Patrick Huang
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-13 06:02 UTC by Ding-Yi Chen
Modified: 2013-11-27 03:35 UTC (History)
3 users (show)

Fixed In Version: 3.1-SNAPSHOT (20130822-1236)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 996432 (view as bug list)
Environment:
Last Closed: 2013-11-27 03:25:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 953734 None None None Never
Red Hat Bugzilla 996432 None None None Never

Internal Links: 953734 996432

Description Ding-Yi Chen 2013-08-13 06:02:14 UTC
Description of problem:
Reviewer only (has reviewer but not translator) role cannot reject translation,
because button "confirm reject" does not do anything. The user needs to click "cancel" to close the dialog.

Version-Release number of selected component (if applicable):
Zanata version 3.0.0-alpha-2-SNAPSHOT (20130813-1420)

How reproducible:
Always

Steps to Reproduce:
1. Login as a user with only reviewer role, but not translator role.
2. Go to Translation editor.
3. Find a non-empty translation, click Reject
4. Enter the comment: "Comment ver1" then click "Confirm rejection"

Actual results:
Nothing happened.

Expected results:
"Why is this translation rejected?" dialog should close, and comment count increase by one.

Additional info:

Comment 1 Sean Flanigan 2013-08-16 07:33:08 UTC
If we are talking about language reviewers (not project/technical reviewers, which aren't implemented yet), then I think it's okay to assume language reviewers are also translators.  So the workaround is for the team coordinator to make sure reviewers are translators too.

Comment 2 Sean Flanigan 2013-08-19 01:17:54 UTC
https://github.com/zanata/zanata-server/pull/130

Comment 3 Sean Flanigan 2013-08-22 01:50:34 UTC
The pull request has now been merged into integration/master (v3.1-SNAPSHOT).

Comment 4 Patrick Huang 2013-08-22 01:59:53 UTC
fixed in pull request:
https://github.com/zanata/zanata-server/pull/130

Comment 5 Ding-Yi Chen 2013-08-22 04:47:51 UTC
VERIFIED with Zanata version 3.1-SNAPSHOT (20130822-1236).

Comment 6 Sean Flanigan 2013-11-27 03:15:39 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 7 Sean Flanigan 2013-11-27 03:16:54 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 8 Sean Flanigan 2013-11-27 03:18:55 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 9 Sean Flanigan 2013-11-27 03:25:00 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 10 Sean Flanigan 2013-11-27 03:33:35 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 11 Sean Flanigan 2013-11-27 03:35:50 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.


Note You need to log in before you can comment on or make changes to this bug.