Bug 996391 - NFS: Memory leak when dbench is run
NFS: Memory leak when dbench is run
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: santosh pradhan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 02:15 EDT by Raghavendra G
Modified: 2014-09-21 18:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 02:52:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
valgrind reports (46.93 KB, text/x-log)
2013-08-13 02:15 EDT, Raghavendra G
no flags Details
val-nfs1 (346.03 KB, text/plain)
2013-08-13 05:47 EDT, Saurabh
no flags Details

  None (edit)
Description Raghavendra G 2013-08-13 02:15:29 EDT
Created attachment 785999 [details]
valgrind reports

Description of problem: When dbench is run on nfs mount, memory usage of nfs server process climbs up and reaches 1.5 GB. The leak seems to be in the form of inodes and memory stored in their contexts.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. dbench -t 100 10
2.
3.

Actual results:
memory usage of nfs server process climbs to 1.5 GB

Expected results:
leak shouldn't happen

Additional info:
Valgrind reports are attached.
Comment 1 santosh pradhan 2013-08-13 02:57:59 EDT
Will have a look.
Comment 3 Saurabh 2013-08-13 05:47:57 EDT
Created attachment 786097 [details]
val-nfs1
Comment 9 santosh pradhan 2013-08-28 02:28:23 EDT
I have addressed all the leaks reported in the valgrind report attached which were related to NFS. In fact, they are not leaks. I ll check with Raghavendra about next steps.
Comment 10 santosh pradhan 2013-08-28 02:52:10 EDT
1) One leak is genuine but that's generic to GlusterFS i.e. the memory returned by syncenv_new(). In fact it saves the chunk in gluster ctx->env which should have been free()'d by glusterfs_ctx_destroy() but there is no code for glusterfs_ctx_destroy() :(. Thats why it's commented out. I don't know history behind this.

2) From NFS point of view, there is no code change needed. 

Based on this, I am marking this as Not-A-Bug. 

Please feel free if you disagree.

Thanks,
Santosh

Note You need to log in before you can comment on or make changes to this bug.