Bug 996411 - GraphicsMagick: support 32 bits per pixel
GraphicsMagick: support 32 bits per pixel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: GraphicsMagick (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 02:44 EDT by Mario Lamas
Modified: 2014-08-20 08:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-20 08:40:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Lamas 2013-08-13 02:44:04 EDT
When I use the imread() function in Octave appears the following message: 

warning: your version of GraphicsMagick limits images to 16 bits per pixel

For a optimal use of image processing in Octave there is the need of 32 bit per pixel but the image quality gonna be poor after the call of the imshow() function.

How reproducible:

- Open QtOctave.
- Use the imread() function with some image.
- Use the imshow() function with the same image called with the imread() function.
- Watch the quality of the image.
Comment 1 Rex Dieter 2014-08-20 08:40:55 EDT
http://wiki.octave.org/GraphicsMagick mentions

Warning: Increasing quantum depth may have a dramatic increase in memory usage. If you use QuantumDepth 32, all images will be read with that precision even if they were saved with 8bit. This means that a 100MB 8bit image will temporarly take 400MB memory, or more if the image was compressed and they usually are, before Octave resizes it back down to 100MB. Because of this, because 32 bit integers images are rare, and because GraphicsMagick does not handle floating point, it's recommended to use QuantumDepth of 16.


We are already using 16


If that wiki entry is not current, please clarify and re-open.

Note You need to log in before you can comment on or make changes to this bug.