Bug 996413 - Include information about the downloadable Maven Repo
Include information about the downloadable Maven Repo
Status: CLOSED DUPLICATE of bug 1090010
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: ---
Assigned To: Vikram Goyal
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 02:46 EDT by lcarlon
Modified: 2014-07-17 21:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 21:24:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lcarlon 2013-08-13 02:46:55 EDT
Productization are working on a Maven Repo for download with the BRMS 6 release.

Documentation needs to know what documentation will be required for users to use the repo.

Specific questions are:

What is the repo for?
How do users configure the repo?
What can customers do with it?
What tasks should be documented for users working with the repo?

Thanks
Lee
Comment 2 lcarlon 2013-09-01 20:24:37 EDT
I have used the EAP 6 Maven documentation as a starting point and changed the name from the JBoss Enterprise Application Platform Maven Repository to the Jboss Integration Maven Repository (but will update once the name has been decided and if it is different from the name used).

http://docbuilder.usersys.redhat.com/13321/#chap-Maven
Comment 3 Petr Široký 2013-09-13 11:49:18 EDT
Lee (or someone from the docs team), is the link above still correct? I can't access that page (Chrome says is does not exists).
Comment 4 lcarlon 2013-09-14 21:47:06 EDT
Hi Petr,

There was a power outage in the Brisbane office (Where the servers hosting those pages are located) over the weekend. The docbuilder pages will be back up from Monday, sorry for the inconvenience.

Thanks
Lee
Comment 5 Petr Široký 2013-09-17 10:24:08 EDT
I have briefly looked at the Maven chapter and it looks really great!

I will leave the BZ ON_QA for now as there are still some things that need to be resolved (naming etc) and honestly I still don't what exactly we will distribute. I will take closer look when all those things are clear and resolve the BZ then.
Comment 6 lcarlon 2013-09-17 17:50:41 EDT
Thanks Petr.

Mentioning this so that you are aware of it (not because I expect you to QE it for every product) but if the repository is indeed a shared repo for Fuse Service Works, Data Virtualization, BRMS, and BPM suite, the intention is to use exactly the same content for each product. For that reason I've avoided any product specifics, but I believe the content should be relevant for each.

Lee
Comment 10 Petr Široký 2014-04-01 11:37:14 EDT
Hello,

I looked over the content again and found that the docs mention that users need to download all previous EAP repos in order to be able to use the B_MS repo. I think that is not correct, users should only need:
 1) The B_MS Maven repo itself
 2) Single EAP repo (in this case 6.1.1)
 3) Access to JBoss public repo (repository.jboss.org)
 4) And access to Maven central.
Comment 12 Vikram Goyal 2014-07-17 21:24:45 EDT

*** This bug has been marked as a duplicate of bug 1090010 ***

Note You need to log in before you can comment on or make changes to this bug.