Bug 996414 - RFE: Reviewer should be able to add new reject comment by clicking reject again
Summary: RFE: Reviewer should be able to add new reject comment by clicking reject again
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michelle Kim
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-13 06:52 UTC by Ding-Yi Chen
Modified: 2015-07-29 02:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 02:13:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 953734 None None None Never

Internal Links: 953734

Description Ding-Yi Chen 2013-08-13 06:52:19 UTC
Description of problem:
A reviewer might add more comments by clicking reject again.

However, if the state is already "Reject", then clicking reject mistakenly does nothing.


Version-Release number of selected component (if applicable):
Zanata version 3.0.0-alpha-2-SNAPSHOT (20130813-1420)

How reproducible:
Always

Steps to Reproduce:
1. Login with reviewer role
2. Go to translation editor
3. Reject a message,
4. Click Reject on that message again.

Actual results:
Nothing happened. 

Expected results:
Review comment dialog shows, ready to enter new comment.

Additional info:

Comment 1 Alex Eng 2013-08-15 05:57:22 UTC
The second reject won't work because of the states of the translation has not changed.

Comment 2 Ding-Yi Chen 2015-03-23 01:47:03 UTC
Alex,

Is there any way to for reviewer to change his/her comments?
If there is, we can close this bug as WONTFIX, as this bug is for reviewers to revise their comments.

Comment 3 Luke Brooker 2015-03-23 02:33:58 UTC
I think the 2 options here are to either add an edit comment function or just to add a new comment. If we want to retain the context of the initial reject, it may be worth adding an edit feature.

I think it should be looked at from a higher level in the new editor as more robust commenting feature/epic as the current commenting/history functionality is pretty basic.

Also, I'm hoping to stop using the term "Reject" in favour of "Issue". So, Approve or Report an Issue.

Comment 4 Alex Eng 2015-03-23 02:38:37 UTC
Dean, 
At the moment, reviewer can't change their existing comment. They can only add new ones.

I like the idea of allow reviewer to edit their comment. Most of review process platform allowing that. e.g. github.

(Thats one thing that bugzilla really needs to implement)

Comment 5 Ding-Yi Chen 2015-03-23 03:13:13 UTC
(In reply to Alex Eng from comment #4)
> (Thats one thing that bugzilla really needs to implement)

As side note, Bugzilla seems to do this on purpose, so no accidental or malicious deletion. Good or Bad in either case.

But in Zanata's case, we can neither add nor edit comment once the reviewer click reject. I am happy with either for Zanata.

Comment 6 Michelle Kim 2015-03-24 05:29:23 UTC
Can I suggest we sit with our marketing reviewers who use the review feature heavily to ask for their opinion on what would be the best way to implement this review comment feature? 

As we only offer the basic review feature, i would like to have a look at the way we can provide more complete review process in Zanata. I will speak to translators with Luke and add more comments here to decide the scope of the review feature. Thanks Michelle

Comment 7 Zanata Migrator 2015-07-29 02:13:11 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-162


Note You need to log in before you can comment on or make changes to this bug.