Bug 996441 - EAP fails to deploy DTGOV after installing S-RAMP+DTGov using the installer.
EAP fails to deploy DTGOV after installing S-RAMP+DTGov using the installer.
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER2
: ---
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 03:46 EDT by Stefan Bunciak
Modified: 2013-09-24 13:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 13:52:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-08-13 03:46:43 EDT
Description of problem:

EAP fails to deploy DTGOV after installing S-RAMP+DTGov using the installer.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install S-RAMP via installer (I used installer which came along with the SOA 6.0.0.ER1 distribution http://dev138.mw.lab.eng.bos.redhat.com/candidate/soa-6.0.0.ER1/jboss-eap-6.1.0.sramp.ci-installer.jar) into EAP 6.1
2. Start server (eap-6.1) with S-RAMP installation

Actual results:

DTGov-ui is missing ErraiService:

09:42:28,113 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014775:    New missing/unsatisfied dependencies:
      service jboss.naming.context.java.jboss.resources.ErraiService (missing) dependents: [service jboss.naming.context.java.module.dtgov-ui-war.dtgov-ui-war.env.ErraiService] 

09:42:28,330 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
09:42:28,331 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
09:42:28,331 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss Red Hat JBoss SRAMP 6.0.0.ER1-redhat-1 (AS 7.2.0.Final-redhat-8) started (with errors) in 13181ms - Started 491 of 609 services (39 services failed or missing dependencies, 76 services are passive or on-demand)


Expected results:

DTGov-ui is successfully deployed.

Additional info:
Comment 1 Thomas Hauser 2013-08-26 14:06:03 EDT
Due to big changes in the installation process, in addition to big changes in the way S-RAMP and DTGov are being distributed, I am not sure how valuable this BZ is. In my opinion, we should re-test to see if this issue emerges in the ER2 installer.
Comment 2 Len DiMaggio 2013-09-24 13:51:52 EDT
Verified to be fixed in ER3.

Note You need to log in before you can comment on or make changes to this bug.