Bug 996456 - firstboot:No proper message when you enter an invalid activation-key while registering
firstboot:No proper message when you enter an invalid activation-key while re...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Alex Wood
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-08-13 04:14 EDT by Shwetha Kallesh
Modified: 2014-01-17 15:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 15:38:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
No proper messaging (105.99 KB, image/png)
2013-08-13 04:14 EDT, Shwetha Kallesh
no flags Details
Activation key firstboot (66.30 KB, image/png)
2014-01-17 15:37 EST, Sharath Dwaral
no flags Details

  None (edit)
Description Shwetha Kallesh 2013-08-13 04:14:33 EDT
Created attachment 786040 [details]
No proper messaging

Description of problem:
firstboot:No proper message when you enter an invalid activation-key while registering

Version-Release number of selected component (if applicable):
[root@localhost ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.19-1
subscription-manager: 1.9.1-1.git.17.168141e.el5
python-rhsm: 1.9.1-1.git.2.9b74ebf.el5


How reproducible:


Steps to Reproduce:
1.firstboot -r 

2. Register using activation-key

3.Enter an invalid activation-key

Actual results:
In the attachment

Expected results:
An alert message should be displayed saying "Unrecognised Activationkey : <Inavlid key entered>"

Additional info:
Comment 2 RHEL Product and Program Management 2013-08-17 01:47:20 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Alex Wood 2013-08-19 16:30:08 EDT
I'm unable to duplicate this bug.  Can I get some more information from you?  Are you registering to Katello, SAM, or just a plain Candlepin instance?  Which version of Katello/SAM/Candlepin are you using?  Can you paste in the trace-back from /var/log/rhsm/rhsm.log when this error occurs?
Comment 4 John Sefler 2013-09-19 09:15:37 EDT
Deferred from RHEL510 to RHEl65 development cycle
Comment 6 Shwetha Kallesh 2013-09-23 08:16:29 EDT
Cannot reproduce the bug,I was registered to plain candlepin instance

[root@rhel65 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.27-1
subscription-manager: 1.10.2-1.git.38.20a82f5.el6
python-rhsm: 1.10.2-1.git.4.3048ab5.el6
Comment 7 Sharath Dwaral 2014-01-17 15:37:02 EST
Created attachment 851781 [details]
Activation key firstboot

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.2-1
subscription-manager: 1.10.10-1.git.22.bf03c6b.el7
python-rhsm: 1.10.10-1.git.1.90486fd.el7


We see an appropriate warning message when an invalid activation key is entered
Please see attachment

VERIFIED

Note You need to log in before you can comment on or make changes to this bug.