Bug 996470 - update to mate-document-viewer-1.6.1-5 fails because of broken dependencies
update to mate-document-viewer-1.6.1-5 fails because of broken dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-document-viewer (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 04:32 EDT by Joachim Backes
Modified: 2013-08-13 05:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 04:47:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-08-13 04:32:08 EDT
Description of problem:
I tried to update to mate-document-viewer from updates-testing, but this is rejected since a lot of days:

yum update --enablerepo=updates-testing

--> Running transaction check
---> Package mate-document-viewer.x86_64 0:1.6.1-3.fc19 will be updated
---> Package mate-document-viewer.x86_64 0:1.6.1-5.fc19 will be an update
---> Package mate-document-viewer-libs.i686 0:1.6.1-3.fc19 will be updated
--> Processing Dependency: mate-document-viewer-libs(x86-32) = 1.6.1-3.fc19 for package: mate-document-viewer-1.6.1-3.fc19.i686
---> Package mate-document-viewer-libs.x86_64 0:1.6.1-3.fc19 will be updated
---> Package mate-document-viewer-libs.i686 0:1.6.1-5.fc19 will be an update
---> Package mate-document-viewer-libs.x86_64 0:1.6.1-5.fc19 will be an update
--> Finished Dependency Resolution
Error: Package: mate-document-viewer-1.6.1-3.fc19.i686 (@updates-testing)
           Requires: mate-document-viewer-libs(x86-32) = 1.6.1-3.fc19
           Removing: mate-document-viewer-libs-1.6.1-3.fc19.i686 (@updates-testing)
               mate-document-viewer-libs(x86-32) = 1.6.1-3.fc19
           Updated By: mate-document-viewer-libs-1.6.1-5.fc19.i686 (updates-testing)
               mate-document-viewer-libs(x86-32) = 1.6.1-5.fc19
           Available: mate-document-viewer-libs-1.6.0-6.fc19.i686 (fedora)
               mate-document-viewer-libs(x86-32) = 1.6.0-6.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):
mate-document-viewer-1.6.1-3.fc19.i686

How reproducible:
always

Steps to Reproduce:
1.See description!
2.
3.

Actual results:


Expected results:


Additional info:

On my box:

rpm -qa mate-document-viewer*
mate-document-viewer-1.6.1-3.fc19.i686
mate-document-viewer-libs-1.6.1-3.fc19.x86_64
mate-document-viewer-1.6.1-3.fc19.x86_64
mate-document-viewer-libs-1.6.1-3.fc19.i686
Comment 1 Joachim Backes 2013-08-13 04:36:26 EDT
I think, on my x86_64 box the i686 versions of mate-document-viewer and mate-document-viewer-libs are not needed, so I erased them.

After this step, the update to mate-document-viewer-libs-1.6.1-5.fc19.x86_64 and mate-document-viewer-1.6.1-5.fc19.x86_64 was performed flawlessly.
Comment 2 Wolfgang Ulbrich 2013-08-13 04:47:56 EDT
In general you don't need i686 mate packages on a x86_64 box, clean your installation.
Comment 3 Joachim Backes 2013-08-13 05:03:50 EDT
(In reply to Wolfgang Ulbrich from comment #2)
> In general you don't need i686 mate packages on a x86_64 box, clean your
> installation.

OK, accepted. By please allow one remark:

mate-document-viewer-1.6.1-3.fc19.i686 was installed on my x86_64 box on Aug 05, but I'm sure, this wasn't done by myself. 

-----------------------------------------------------------------
The history of installed mate-document-viewer* packages is:


Jul 03 07:20:47 Installed: mate-document-viewer-data-1.6.0-6.fc19.noarch
Jul 03 07:20:49 Installed: mate-document-viewer-1.6.0-6.fc19.x86_64
Jul 03 07:20:50 Installed: mate-document-viewer-libs-1.6.0-6.fc19.x86_64
Aug 05 05:55:43 Installed: mate-document-viewer-1.6.1-3.fc19.x86_64
Aug 05 05:55:45 Updated: mate-document-viewer-libs-1.6.1-3.fc19.x86_64
Aug 05 05:55:52 Installed: mate-document-viewer-libs-1.6.1-3.fc19.i686
Aug 05 05:55:53 Installed: mate-document-viewer-1.6.1-3.fc19.i686
Aug 05 05:55:55 Erased: mate-document-viewer-data-1.6.0-6.fc19.noarch

So can you explain why mate-document-viewer-1.6.1-3.fc19.i686 was installed?
Comment 4 Wolfgang Ulbrich 2013-08-13 05:24:14 EDT
Ok, sorry not your fault.
mate-document-viewer-1.6.1-3.fc19.x86_64 in updates-testing was obsolete by mate-document-viewer-1.6.1-4.fc19, because of this multilib issue.
http://koji.fedoraproject.org/koji/buildinfo?buildID=454334
But it was only for one day in updates-testing :(

Note You need to log in before you can comment on or make changes to this bug.