Bug 996474 - [RHEV-RHS] - remove-brick operation on distribute-replicate RHS 2.1 volume, used as VM image store on RHEV, leads to VM corruption
[RHEV-RHS] - remove-brick operation on distribute-replicate RHS 2.1 volume, u...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
All Linux
high Severity high
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 923555 963896
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 04:37 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 923555
Environment:
virt rhev integration
Last Closed: 2014-04-17 09:13:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-13 04:54:48 EDT
REVIEW: http://review.gluster.org/5577 (cluster/dht: Del GF_READDIR_SKIP_DIRS key from dict for first_up) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-08-18 08:02:06 EDT
COMMIT: http://review.gluster.org/5577 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 2a195787746a6bfd3e1da6bf38c657ae0ccda24d
Author: shishir gowda <sgowda@redhat.com>
Date:   Mon Aug 12 17:25:12 2013 +0530

    cluster/dht: Del GF_READDIR_SKIP_DIRS key from dict for first_up
    
    Currently, we sent GF_READDIR_SKIP_DIRS for all subvolumes if
    first_subvol != first_up_subvolume.
    
    Also first_up_subvolume can change with-in the life of a call and
    cbk. Saving the first_up_subvol in dht_local for checks.
    
    Change-Id: I6e369e63f29c9761993f2a66ed768c424bb44d27
    BUG: 996474
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5577
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Anand Avati 2013-12-10 04:13:01 EST
REVIEW: http://review.gluster.org/6468 (cluster/dht: Del GF_READDIR_SKIP_DIRS key from dict for first_up) posted (#1) for review on release-3.4 by Shishir Gowda (gowda.shishir@gmail.com)
Comment 6 Anand Avati 2013-12-14 08:28:45 EST
COMMIT: http://review.gluster.org/6468 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 6677b97f2d17699c74779922cf310adf8bff5558
Author: shishir gowda <gowda.shishir@gmail.com>
Date:   Tue Dec 10 14:42:05 2013 +0530

    cluster/dht: Del GF_READDIR_SKIP_DIRS key from dict for first_up
    
    Currently, we sent GF_READDIR_SKIP_DIRS for all subvolumes if
    first_subvol != first_up_subvolume.
    
    Also first_up_subvolume can change with-in the life of a call and
    cbk. Saving the first_up_subvol in dht_local for checks.
    
    Back porting fix http://review.gluster.org/5577
    
    BUG: 996474
    Change-Id: I67b5bbe781e12812557b569b7d0a0beba4224159
    Signed-off-by: shishir gowda <gowda.shishir@gmail.com>
    Reviewed-on: http://review.gluster.org/6468
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 7 Niels de Vos 2014-04-17 09:13:55 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.