Bug 996481 - It still add repos to redhat.repo after host has subscribed the Data Center subscription
It still add repos to redhat.repo after host has subscribed the Data Center s...
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: rhsm-rhel70 sam20-tracker
  Show dependency treegraph
 
Reported: 2013-08-13 04:59 EDT by Liushihui
Modified: 2014-01-13 07:48 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-13 07:48:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2013-08-13 04:59:42 EDT
Description of problem:
After host has subscribed the Data Center subscription, Run subscription-manager repos --list, it displays a lot of RHEL repos

Version-Release number of selected component (if applicable):
subscription-manager-1.8.19-1.el5
python-rhsm-1.8.16-1.el5
virt-who-0.7-9.el5
katello-headpin-1.4.3-6.el6sam_splice.noarch
candlepin-0.8.19-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1.Register host to SAM server.
2.Restart virt-who on the host(The default mode:Use libvirt to list virtual guests).
3.Register one guest(have 4 sockets) to SAM server with same username and password. 
4.On the Host: subscribe to the DataCenter subscription pool. 
 #subscription-manager subscribe --pool=[DataCenter subscription pool id]
5.Check the repos 
#subscription-manager repos --list 
#rct cat-cert /etc/pki/entitlement/<serial>.pem on the granted data center entitlement.

Actual results:
It still displays a lot of RHEL repos in the hosts after step4

Expected results:
It should no repos display in the hosts. and it also should no repo have been added to redhat.repo

Additional info:
Comment 1 Amanda Carter 2013-08-14 10:40:42 EDT
This sounds like a bug that was in IT that prevented us from properly removing content from the host subscription. We had this manually fixed in stage a week or so ago but it may not have triggered a refresh on the pool.

https://bugzilla.redhat.com/show_bug.cgi?id=969659

Could you please provide the login you're using to test this so that I can take a look at the account?
Comment 3 Amanda Carter 2013-08-21 12:28:12 EDT
Sorry, I didn't see an update on this bug until now. I can ask SAM QE to verify.
Comment 4 Michael Stead 2013-08-28 07:44:19 EDT
Amanda, has this been addressed? Wondering if there is any work here for the team.
Comment 5 Amanda Carter 2013-08-28 10:10:38 EDT
Suresh was verifying this on the SAM side since this was reported during SAM testing. JSefler has validated in another stream that this works as expected against hosted. I'll change the component here to SAM for clarity.
Comment 6 Bryan Kearney 2013-08-29 13:15:58 EDT
moving ot on_qa to have it tested in SAM
Comment 7 Liushihui 2013-09-08 23:42:20 EDT
It still exist on the SAM-1.3.0-RHEL-6-snapshot5, Therefore, Reopen it.

Retest env:
subscription-manager-1.8.21-1.el5
python-rhsm-1.8.17-1.el5
virt-who-0.7-9.el5
katello-headpin-1.4.3-12.el6sam_splice.noarch
candlepin-0.8.25-1.el6sam.noarch

Steps to Reproduce:
1.Register host to SAM server.
2.Restart virt-who on the host(The default mode:Use libvirt to list virtual guests).
3.On the host: List the available subscription 
# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium
SKU:               RH00003
Pool ID:           8ac28c164100a78e014100ac0d310107
Quantity:          20
Service Level:     Premium
Service Type:      L1-L3
Multi-Entitlement: Yes
Ends:              07/11/2014
System Type:       Physical

Subscription Name: Red Hat Enterprise Linux Server, Datacenter Standard
SKU:               RH00002
Pool ID:           8ac28c164100a78e014100ac0ce600ef
Quantity:          2
Service Level:     Standard
Service Type:      L1-L3
Multi-Entitlement: Yes
Ends:              07/11/2014
System Type:       Physical

4.On the Host: subscribe to the DataCenter subscription pool. 
# subscription-manager subscribe --pool=8ac28c164100a78e014100ac0ce600ef
5.Check the repos 
#subscription-manager repos --list

Actually Result:
It still displays a lot of RHEL repos in the hosts after step5, The repos as the following:
#subscription-manager repos --list
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   rhel-5-server-rpms
Repo Name: Red Hat Enterprise Linux 5 Server (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/os
Enabled:   1

Repo ID:   rhel-5-server-cf-tools-1-source-rpms
Repo Name: Red Hat CloudForms Tools for RHEL 5 (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/cf-tools/1/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-supplementary-beta-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Supplementary Beta (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/supplementary/os
Enabled:   0

Repo ID:   rhel-5-server-cf-tools-1-beta-rpms
Repo Name: Red Hat CloudForms Tools for RHEL 5 Beta (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/cf-tools/1/os
Enabled:   0

Repo ID:   rhel-5-server-supplementary-debuginfo
Repo Name: Red Hat Enterprise Linux 5 Server - Supplementary (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/supplementary/debug
Enabled:   0

Repo ID:   rhel-5-server-rhev-agent-debug-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 5 Server (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/rhev-agent/3/debug
Enabled:   0

Repo ID:   rhel-5-server-rhev-agent-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 5 Server (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/rhev-agent/3/os
Enabled:   1

Repo ID:   rhel-5-server-vt-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Virtualization (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/vt/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-supplementary-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Supplementary (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/supplementary/source/SRPMS
Enabled:   0

Repo ID:   rhel-server-dts-5-rhb-source-rpms
Repo Name: Red Hat Developer Toolset RHB Source RPMs for Red Hat Enterprise Linux 5 Server
Repo URL:  https://samserv.redhat.com:8088/content/rhb/rhel/server/5/$releasever/$basearch/devtoolset/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-vt-beta-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Virtualization Beta (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/vt/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-beta-debug-rpms
Repo Name: Red Hat Enterprise Linux 5 Server Beta (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/debug
Enabled:   0

Repo ID:   rhel-5-server-cf-tools-1-rpms
Repo Name: Red Hat CloudForms Tools for RHEL 5 (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/cf-tools/1/os
Enabled:   1

Repo ID:   rhel-5-server-vt-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Virtualization (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/vt/os
Enabled:   0

Repo ID:   rhel-5-server-productivity-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Optional Productivity Applications (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/productivity/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-rhev-agent-source-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 5 Server (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/rhev-agent/3/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-supplementary-beta-debuginfo
Repo Name: Red Hat Enterprise Linux 5 Server - Supplementary Beta (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/supplementary/debug
Enabled:   0

Repo ID:   rhel-5-server-productivity-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Optional Productivity Applications (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/productivity/os
Enabled:   0

Repo ID:   rhel-5-server-debug-rpms
Repo Name: Red Hat Enterprise Linux 5 Server (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/debug
Enabled:   0

Repo ID:   rhel-5-server-vt-debug-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Virtualization (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/vt/debug
Enabled:   0

Repo ID:   rhel-5-server-beta-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server Beta (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-rhev-agent-beta-debug-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 5 Server Beta (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/rhev-agent/3/debug
Enabled:   0

Repo ID:   rhel-5-server-rhev-agent-beta-source-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 5 Server Beta (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/rhev-agent/3/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-supplementary-beta-source-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Supplementary Beta (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/supplementary/source/SRPMS
Enabled:   0

Repo ID:   rhel-5-server-vt-beta-debug-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Virtualization Beta (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/vt/debug
Enabled:   0

Repo ID:   rhel-5-server-supplementary-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Supplementary (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/supplementary/os
Enabled:   0

Repo ID:   rhel-5-server-vt-beta-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Virtualization Beta (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/vt/os
Enabled:   0

Repo ID:   rhel-server-dts-5-rhb-debug-rpms
Repo Name: Red Hat Developer Toolset RHB Debug RPMs for Red Hat Enterprise Linux 5 Server
Repo URL:  https://samserv.redhat.com:8088/content/rhb/rhel/server/5/$releasever/$basearch/devtoolset/debug
Enabled:   0

Repo ID:   rhel-5-server-beta-rpms
Repo Name: Red Hat Enterprise Linux 5 Server Beta (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/os
Enabled:   0

Repo ID:   rhel-5-server-cf-tools-1-beta-source-rpms
Repo Name: Red Hat CloudForms Tools for RHEL 5 Beta (Source RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/cf-tools/1/source/SRPMS
Enabled:   0

Repo ID:   rhel-server-dts-5-rhb-rpms
Repo Name: Red Hat Developer Toolset RHB RPMs for Red Hat Enterprise Linux 5 Server
Repo URL:  https://samserv.redhat.com:8088/content/rhb/rhel/server/5/$releasever/$basearch/devtoolset/os
Enabled:   0

Repo ID:   rhel-5-server-productivity-debug-rpms
Repo Name: Red Hat Enterprise Linux 5 Server - Optional Productivity Applications (Debug RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/dist/rhel/server/5/$releasever/$basearch/productivity/debug
Enabled:   0

Repo ID:   rhel-5-server-rhev-agent-beta-rpms
Repo Name: Red Hat Enterprise Virtualization Agents for RHEL 5 Server Beta (RPMs)
Repo URL:  https://samserv.redhat.com:8088/content/beta/rhel/server/5/$releasever/$basearch/rhev-agent/3/os
Enabled:   0
Comment 8 Michael Stead 2014-01-09 14:18:41 EST
This may be due to the fact that the datacenter subscription that is being attached to the host is not correctly configured, and is behaving like a standard subscription.

When a subscription is created, the following properties are applied to the main pool (anything added here is available to the host):
productAttributes, 
productId,
productName, 
providedProducts

The following properties will be used to create the sub-pool when the host attaches the subscription:
derivedProductAttributes, 
derivedProductId,
derivedProductName, 
derivedProvidedProducts

Once a subscription is defined in this way, a sub-pool will be created from the derived* properties (consumable by guests).

I can't seem to find the exact sub/pool used by the reporter, but if tested against latest stage deployment we could confirm.
Comment 9 Liushihui 2014-01-11 04:52:38 EST
It can't reproduce on the RHEL-7.0-20140108.0-Server-x86_64(KVM) against SAM-1.3.1-RHEL-6-20131219.1

Version-Release number of selected component :
subscription-manager-1.10.10-1.el7.x86_64
python-rhsm-1.10.10-1.el7.x86_64
virt-who-0.8-11.el7.noarch
katello-headpin-1.4.3.23-1.el6sam_splice.noarch
candlepin-0.8.26.0-1.el6sam.noarch

env:
SAM server:10.66.13.79 username/password:admin/admin

Steps to Reproduce:
1. Register host to SAM server.
2. Restart virt-who on the host(The default mode:Use libvirt to list virtual guests).
3. On the host: List the available subscription 
# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux for Virtual Datacenters, Standard
Provides:          
SKU:               RH00002
Contract:          10318833
Pool ID:           8ac28c0c43702c550143704b2c130347
Available:         20
Suggested:         2
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: 
Ends:              01/05/2015
System Type:       Physical

4. On the Host: subscribe to the DataCenter subscription pool. 
# subscription-manager subscribe --pool=8ac28c0c43702c550143704b2c130347
Successfully attached a subscription for: Red Hat Enterprise Linux for Virtual Datacenters, Standard

5. On the host: Check the content after granted data center entitlement
#rct cat-cert /etc/pki/entitlement/<serial>.pem | more
+-------------------------------------------+
	Entitlement Certificate
+-------------------------------------------+

Certificate:
	Path: /etc/pki/entitlement/9017847348185794055.pem
	Version: 3.2
	Serial: 9017847348185794055
	Start Date: 2014-01-05 05:00:00+00:00
	End Date: 2015-01-05 04:59:59+00:00
	Pool ID: 8ac28c0c43702c550143704b2c130347

Subject:
	CN: 8ac28c0c43702c550143803f29fa03bb

Issuer:
	C: US
	CN: samserv.redhat.com
	L: Raleigh
	O: SomeOrg
	OU: SomeOrgUnit
	ST: North Carolina


Order:
	Name: Red Hat Enterprise Linux for Virtual Datacenters, Standard
	Number: 
	SKU: RH00002
	Contract: 10318833
	Account: 5363862
	Service Level: Standard
	Service Type: L1-L3
	Quantity: 20
	Quantity Used: 1
	Socket Limit: 2
	RAM Limit: 
	Core Limit: 
	Virt Only: False
	Subscription: 
	Stacking ID: RH00002
	Warning Period: 0
	Provides Management: False
	
Actual results:
The host hasn't get any content, it's correct.

Note You need to log in before you can comment on or make changes to this bug.