Bug 996556 - Uploading same manifest to same org: 500 error, 'Unable to create base dir for sync: /var/cache/candlepin/sync'
Uploading same manifest to same org: 500 error, 'Unable to create base dir f...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Kedar Bidarkar
: Regression, Triaged
Depends On: 886909
Blocks: 886931
  Show dependency treegraph
 
Reported: 2013-08-13 08:41 EDT by Bryan Kearney
Modified: 2014-06-16 15:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 886909
Environment:
Last Closed: 2014-06-16 15:55:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 RHEL Product and Program Management 2013-09-17 00:19:24 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 Kedar Bidarkar 2013-10-21 07:21:45 EDT
the same behaviour is seen as said in https://bugzilla.redhat.com/show_bug.cgi?id=886909#c17
Comment 7 Bryan Kearney 2013-10-30 12:29:40 EDT
Per coment 17, the fix should be to not log the 409 to stdout, since that is a valid use case:

2013-10-30T12:27:21-0400: [Worker(delayed_job host:sam13 pid:1635)] Provider#queue_import_manifest failed with RestClient::Conflict: Resources::Candlepin::Owner: 409 Conflict {"displayMessage":"Import is the same as existing data","requestUuid":"17f3fb96-525f-4c3c-8d43-721578bcd05e","conflicts":["MANIFEST_SAME"]} (POST /candlepin/owners/ACME_Corporation/imports) - 0 failed attempts
2013-10-30T12:27:21-0400: [Worker(delayed_job host:sam13 pid:1635)] PERMANENTLY removing Provider#queue_import_manifest because of 1 consecutive failures.
Resources::Candlepin::Owner: 409 Conflict {"displayMessage":"Import is the same as existing data","requestUuid":"17f3fb96-525f-4c3c-8d43-721578bcd05e","conflicts":["MANIFEST_SAME"]} (POST /candlepin/owners/ACME_Corporation/imports)
Comment 8 Bryan Kearney 2013-10-30 13:12:08 EDT
removing the blockers since it is now a logging issue.
Comment 12 Mike McCune 2014-06-16 15:55:27 EDT
This is no longer occuring in the latest builds.  Please re-open if it starts to happen again.

Note You need to log in before you can comment on or make changes to this bug.