Bug 996562 - [RFE] Environment renaming should be enabled
[RFE] Environment renaming should be enabled
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Hayk Hovsepyan
: FutureFeature, Triaged
Depends On: 795928
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 08:50 EDT by Bryan Kearney
Modified: 2014-09-18 12:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 795928
Environment:
Last Closed: 2014-04-24 13:09:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2013-08-13 08:50:19 EDT
+++ This bug was initially created as a clone of Bug #795928 +++

See 787226 for reasons renaming was disabled. This disable, though, is only a short-term fix to avoid larger issues and needs to be resolved.

-----
Since we base the repoid in pulp off of the environment name, we really
shouldn't be able to rename it, as it could cause problems. 

One such scenario that could cause issues:


1. create environment Dev
2. promote repo X to dev
3. rename environment Dev to Foo
4. Create a new environment called Dev after Foo
5. promote repo X to Dev


Since the repo was already created in an environment called Dev, the repo
promotion would fail.  


Ideally we wouldn't be basing repo_id off of environment name.  There was some
discussion on having an immutable label field, which should allow us to have a
name that is changeable, but this is probably post V1.


We need to block this in the UI and the api.

--- Additional comment from Lukas Zapletal on 2012-12-18 10:14:16 EST ---

Ok this can be closed too: https://bugzilla.redhat.com/show_bug.cgi?id=807055

--- Additional comment from Justin Sherrill on 2012-12-18 10:29:31 EST ---



--- Additional comment from Tom McKay on 2012-12-18 13:44:40 EST ---

https://github.com/Katello/katello/pull/1281

--- Additional comment from Bryan Kearney on 2013-06-06 16:50:15 EDT ---

Moving all POST / MODIFIED bugs to ON_QA due to the new builds.
Comment 1 Mike McCune 2013-08-16 14:14:03 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 2 RHEL Product and Program Management 2013-09-17 00:19:05 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Hayk Hovsepyan 2013-10-11 08:28:01 EDT
Verified on revision:
signo-0.0.22-2.el6sat.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-1.3.0-15.el6sat.noarch
katello-cli-common-1.4.3-19.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.25-1.el6sam.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-pulp-1.4.6-29.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-12.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
foreman-postgresql-1.3.0-15.el6sat.noarch
katello-cli-1.4.3-19.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-10.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-glue-candlepin-1.4.6-29.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-29.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
katello-configure-foreman-1.4.5-10.el6sat.noarch
katello-foreman-all-1.4.6-29.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
candlepin-cert-consumer-ares.usersys.redhat.com-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-configure-1.4.5-10.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-common-1.4.6-29.el6sat.noarch
katello-glue-elasticsearch-1.4.6-29.el6sat.noarch
katello-all-1.4.6-29.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-7.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 6 Bryan Kearney 2014-04-24 13:09:52 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 7 Bryan Kearney 2014-04-24 13:11:15 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.