Bug 996571 - CopyImageGroupCommand is broken: Unexpected token
CopyImageGroupCommand is broken: Unexpected token
Status: CLOSED DUPLICATE of bug 996005
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
TestBlocker
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 08:59 EDT by Ohad Basan
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 09:13:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (17.10 MB, text/x-log)
2013-08-13 09:03 EDT, Ohad Basan
no flags Details

  None (edit)
Description Ohad Basan 2013-08-13 08:59:22 EDT
Description of problem:

2013-08-12 15:40:22,255 ERROR [org.ovirt.engine.core.bll.CopyImageGroupCommand] (ajp-/127.0.0.1:8702-5) Error during CreateTask for command: org.ovirt.engine.core.bll.CopyImageGroupCommand. Exception org.apache.
commons.lang.SerializationException: org.codehaus.jackson.map.JsonMappingException: Unexpected token (START_OBJECT), expected START_ARRAY: need JSON Array to contain As.WRAPPER_ARRAY type information for class j
ava.util.Map
 at [Source: java.io.StringReader@57a4f37; line: 148, column: 29] (through reference chain: org.ovirt.engine.core.common.action.ImportVmTemplateParameters["vmTemplate"]->org.ovirt.engine.core.common.businessenti
ties.VmTemplate["diskMap"]): org.apache.commons.lang.SerializationException: org.codehaus.jackson.map.JsonMappingException: Unexpected token (START_OBJECT), expected START_ARRAY: need JSON Array to contain As.WR
APPER_ARRAY type information for class java.util.Map
 at [Source: java.io.StringReader@57a4f37; line: 148, column: 29] (through reference chain: org.ovirt.engine.core.common.action.ImportVmTemplateParameters["vmTemplate"]->org.ovirt.engine.core.common.businessenti
ties.VmTemplate["diskMap"])
Comment 1 Ohad Basan 2013-08-13 09:03:58 EDT
Created attachment 786150 [details]
engine log
Comment 2 Ohad Basan 2013-08-13 09:13:44 EDT

*** This bug has been marked as a duplicate of bug 996005 ***

Note You need to log in before you can comment on or make changes to this bug.