Bug 996576 - Unfence at cluster startup with fence_scsi
Unfence at cluster startup with fence_scsi
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pacemaker (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Andrew Beekhof
Cluster QE
:
Depends On: 1009067 1009069
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 09:08 EDT by Jaroslav Kortus
Modified: 2014-06-18 00:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: pacemaker-1.1.10-16.el7
Doc Type: Bug Fix
Doc Text:
Cause: Fencing is configured in Pacemaker not cman Consequence: The call to fence_node -U in the cman init script is a no-op Fix: Support the concept of automated unfencing in pacemaker Result: Messages such as these should be visible in the log files during startup: stonith-ng[7472]: notice: cib_device_update: Unfencing ourselves with fence_scsi (Fabric) ... stonith-ng[7472]: notice: log_operation: Operation 'on' [7485] (call -1 from stonith-ng) for host 'pcmk-5' with device 'Fabric' returned: 0
Story Points: ---
Clone Of:
: 996850 (view as bug list)
Environment:
Last Closed: 2014-06-13 08:02:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Kortus 2013-08-13 09:08:01 EDT
Description of problem:
Pure pacemaker + fence_scsi does not provide complete fencing solution. The node needs to register with the device on which it's supposed to write prior to any write action.

Until now this was done with cman + <unfence> mechanics which triggered fence_node -U at startup. Currently with pure pacemaker+corosync combo there is no trick to fire the same operation and get the node registered.

Please provide a way to do such an action and sucessfully register with the device.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. setup a cluster with fence_scsi and compliant shared disk
2. startup the cluster
3. verify keys on the devices (sg_persist)

Actual results:
no keys present

Expected results:
keys present as in cman 

Additional info:
Comment 2 Andrew Beekhof 2013-08-13 20:45:35 EDT
I should have a functioning patch later today.
We'll also need to clone this for RHEL6.5 since 'fence_node -U' is a no-op when cluster.conf only references pcmk_fence.

In any case, stonithd wouldn't be running to allow it to succeed.
The same patch will address the issue in both versions.
Comment 3 Andrew Beekhof 2013-08-14 03:01:02 EDT
A related patch has been committed upstream:
  https://github.com/beekhof/pacemaker/commit/8af0d0c

with subject:

   Feature: Fencing: Support agents that need the host to be unfenced at startup

Further details (if any):
Comment 8 Ludek Smid 2014-06-13 08:02:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.