Bug 996579 - ReleaseId element is missing in kie-spring.xsd
ReleaseId element is missing in kie-spring.xsd
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mario Fusco
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-13 09:19 EDT by Ivo Bek
Modified: 2014-08-06 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-08-13 09:19:05 EDT
Description of problem:

There is no possibility how to set releaseId in beans.xml even though the namespace handler expects this element, so I think it is only missing in the kie-spring.xsd - https://github.com/droolsjbpm/droolsjbpm-integration/blob/master/kie-spring/src/main/resources/org/kie/spring/kie-spring-6.0.0.xsd

The namespace handler expects "releaseId" here https://github.com/droolsjbpm/droolsjbpm-integration/blob/master/kie-spring/src/main/java/org/kie/spring/namespace/KieSpringNamespaceHandler.java

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mario Fusco 2013-08-19 09:21:15 EDT
The releaseId was necessary only to associate with the correct kmodule, due to separate XML files. Now that it is possible to declare kmodules directly in the spring context files this is no longer useful so I just removed it.
Comment 5 Ivo Bek 2014-03-18 06:09:43 EDT
This BZ really doesn't need to be tested that the releaseId has been removed from kie-spring.xsd.

Note You need to log in before you can comment on or make changes to this bug.