This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 996596 - [RFE] Make resource type schemata available in Heat API
[RFE] Make resource type schemata available in Heat API
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: Upstream M3
: 4.0
Assigned To: Zane Bitter
Angus Salkeld
https://blueprints.launchpad.net/heat...
: FutureFeature, OtherQA
Depends On: 1042645
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-08-13 09:47 EDT by Zane Bitter
Modified: 2016-04-26 19:10 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-heat-2013.2-0.8.b3.el6ost
Doc Type: Enhancement
Doc Text:
Schema properties of each available resource type are now presented through the Orchestration API. Consequently, automated Orchestration clients are able to query the properties of a resource type.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:19:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zane Bitter 2013-08-13 09:47:04 EDT
Add an API to Heat for getting the schema for any available resource type.
Comment 5 Ami Jeain 2013-10-28 07:40:05 EDT
QANAK'ing due to QE capacity
Comment 9 Angus Salkeld 2013-12-11 19:38:48 EST
I can see the code is in rhos:
grep resource_types /usr/lib/python2.6/site-packages/heat/api/openstack/v1/__init__.py
            stack_mapper.connect("resource_types",
                                 "/resource_types",
                                 action="list_resource_types",
                                 "/resource_types/{type_name}",
                                 "/resource_types/{type_name}/template",


But there is no support for this feature in the client, so I didn't actually test it. :(

I have made an upstream bug for it: https://bugs.launchpad.net/python-heatclient/+bug/1260130
Comment 10 Angus Salkeld 2013-12-11 21:19:05 EST
https://review.openstack.org/#/c/61624/
Comment 14 Angus Salkeld 2013-12-18 15:31:31 EST
I verified using an upstream heat client against rhos:

$ heat resource-type-list
+------------------------------------------+
| resource_type                            |
+------------------------------------------+
| AWS::EC2::Instance                       |
| OS::Nova::Server                         |
| AWS::CloudFormation::Stack               |
...

$ heat resource-type-show AWS::EC2::VPC
{
  "attributes": {}, 
  "properties": {
    "CidrBlock": {
      "required": false, 
      "type": "string"
    }, 
    "Tags": {
      "required": false, 
      "type": "list", 
      "schema": {
        "*": {
          "required": false, 
          "type": "map", 
          "schema": {
            "Value": {
              "required": true, 
              "type": "string"
            }, 
            "Key": {
              "required": true, 
              "type": "string"
            }
          }
        }
      }
    }
  }, 
  "resource_type": "AWS::EC2::VPC"
}
Comment 16 errata-xmlrpc 2013-12-19 19:19:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.